Several friends and I are playing Star Wars: The Old Republic. We use my Ventrilo server to chat, and have done so for years in other games (World of Warcraft, League of Legends, etc.)

With Star Wars: The Old Republic, two (and only two!) of said friends are having issues with Push to Talk (PTT). For some reason, when the game is focused, their PTT keys no longer work - holding the key down does nothing.

The facts:

  • If they unfocus the game, PTT works again until they go back in.
  • Toggling on/off the "Use Direct Input" option did not change behavior.
  • They are both using Fullscreen (Windowed) mode and Windows 7 (as are many of us).
  • I do not know precisely which keys they are trying to use for PTT, but I know Middle Mouse was attempted.
  • Turning off PTT does work, but they prefer to use PTT.
  • Just these 2 of all my friends have the issue, and only with Star Wars: The Old Republic.

Has anyone else seen and resolved this issue, or know of good debugging steps to help us resolve it?

  • 1
    start vent as administrator, i had same issues in other games
    – Templar
    Commented Dec 22, 2011 at 17:04
  • Works for me when I run it as an administrator. What's so bad about running as admin?
    – user17684
    Commented Jan 3, 2012 at 17:14

4 Answers 4


Try having them open Vent as Administrator. I have heard that it fixed this for a few of my guildmates.

Doing some further research into this. It seems like this has been a problem since beta. There seems to be an issue with how SWTOR is handling key presses. People are having problems with the keys they bind as well. An example, if you bind left control SWTOR is treating it as a modifier even if you don't have CTRL + (any key) bound to anything. This can prevent you from moving and activating abilities.

I haven't had a problem with Vent myself, but I use dual monitors and vent is open on the monitor that the game isn't on. No problems passing my PTT key then.

For the time being, set Vent to "Run as Administrator" by default.

  • This fixed it for me too.
    – Mufasa
    Commented Dec 22, 2011 at 17:15

Windows 7 security doesn't allow global OS key binds without running with administrator rights.

Open Ventrilo as an administrator to enable push-to-talk to work when another game is active.

You can open as an administrator by going to the shortcut Properties, Compatibility tab, and checking "Run this program as an administrator". Or, you can Ctrl + Shift + Left Click on the shortcut every time you launch it.

I suggest the first option, so that sometimes no one can here you because sometimes you remember and sometimes forget to launch it with admin rights.

Every time you launch Ventrilo with admin rights, with either option above, Windows will bring up the "Do you want to allow this program ... to make changes..." security dialog where you have to click "Yes". Not fun, but that's what it takes to get through security.

  • Why is this not an issue for other games, then?
    – Mag Roader
    Commented Dec 22, 2011 at 18:43
  • @MagRoader: I'm not sure of the technical details. It's the way Ventrilo, Windows 7, and some games interact with the various APIs and settings. But this is a common problem with several games and Ventrilo, and the standard solution.
    – Mufasa
    Commented Dec 22, 2011 at 21:40

Running as Administrator and restarting SW:TOR worked for me


I solved this problem in the vent settings by

  • unclicking Use Direct Input ...
  • Clicking Discard Hotkey

I can walk and talk with the control key now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .