I'm trying to install WorldEdit, and I've done the following:

  • Gotten the craftbukkit JAR,
  • run it, stopped it,
  • replaced world with my save from single,
  • run again, stopped again,
  • copied WorldEdit.jar into plugins,
  • tried //hpos1 and other WorldEdit commands.

I get the following error:

You don't have permission to do this

What causes this? (I'm on a Mac, if that's a factor)

  • what are you using as permissions plugin / are you using a permissions plugin? Dec 25, 2011 at 9:47
  • @alexanderpas i dont use any permissions plugin. Somehow i managed to get myself permitted with pure WorldEdit on an ooold software. Didnt know it changed... Which is the best permission plugin ?
    – imacake
    Dec 25, 2011 at 9:57
  • Perhaps try oopping yourself, If you do not want to use a permissions plugin. Just type /op <username> in the console. This should work.
    – Jonny
    Dec 30, 2011 at 6:27

2 Answers 2


Due to the nature of worldedit, worldedit requires you to specify permissions, either the build in, or by using a permissions plugin

Worldedit uses the WEPIF (WorldEdit Permissions Interoperability Framework) to handle permissions.

If you're not using a permissions plugin, the easiest way is using Flat file permissions which allows you to simply give yourself all permissions by editing two files in the root of your server (same location as bukkit itself):





(replace sk89q with your username)

There's a list of permissions, on the Worldedit Wiki which can help you if you want to further specify permissions

  • 1
    I am sorry but that does not seem to work... Maybe im not in the group 'admins' ? (Really, which perms plugin do you recommend? plugins.bukkit.org/…)
    – imacake
    Dec 25, 2011 at 10:21
  • nevermind! works! perfect! Ive messed too much with worldedit's config.yml, sorry! Thanks!
    – imacake
    Dec 25, 2011 at 10:43
  • @alexanderpas I'm doing it for him.
    – Bogdacutu
    Dec 25, 2011 at 15:44
  • He can't upvote until he reaches 15 rep, remember? :) Dec 25, 2011 at 17:16

I realize this is a very old thread but for those players who still need help I will offer my limited experience. Recently the bukkit commands have changed to include minecraft commands that basically have the same permissions but are preceded with minecraft instead of bukkit. For example: - bukkit.command.op


  • minecraft.command.op

and so on.

I had the same problem described above and solved it by adding all the minecraft.commands to my perms. I use Groupmanager. I found this information at: http://wiki.bukkit.org/CraftBukkit_Commands

The new perms are listed under Mojang Permission on the spreadsheet.

I suspect bukkit is being phased out to be replaced by a Microsoft system under the heading of Mojang.

Regardless, I no longer get the dreaded fail message. :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .