Having bit of a trouble completing "Forbidden Legend" quest. I'm at the forging of amulet part. After having fought the ghost of three brothers, Gauldur's ghost shows up. However, it doesn't do anything, just stands there.

If I understand correctly, Gauldur is supposed to forge the amulet for me. But he doesn't. I've done the sequence 3 times, however, everytime, the ghost just stands there.

Has anyone run into this? What was the fix?

I'm playing on a PC.

  • have you tried attacking the ghost? :) – GmNoob Dec 25 '11 at 18:37
  • yes. he's up on a unreachable area. sort of like a pedestal. Unrelenting Force, flames, sparks, bow, etc have not affect on him. – Nasir Dec 25 '11 at 19:13

alright, 4th time around, it worked.

Have to make sure that you don't disintegrate/obliterate any of the three bosses. kill them slowly, until they teleport back to the pedestal. Then Gauldur kills them and reforges the amulet for you.


I had trouble with this as well. The only solution that worked for me was to send my follower home, walk into the hallway and tell the other two (Erbin? And the woman from the tavern) to wait outside the chamber. Then it worked.


For future reference, a fix is to open console with ` then left click on gauldur and type in disable then enable


I was confused at this point in the quest as well, but if you look down you should see a new amulet and the 3 old amulets missing.

  • nope, all 3 are still there :( – Nasir Dec 25 '11 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.