I am currently running OS X 10.7.2 with an updated version of Steam installed. I recently downloaded the Team Fortress 2 Beta to this Mac and then removed it via Steam's "Delete Local Game Content." This has left the "Team Fortress 2 Beta" icon stuck on the Launchpad, and I cannot remove it.

All of the typical methods for removing an icon have not worked (i.e., dragging to trash, Control+Option+Command+Left-Click, holding down left-click over the icon until icons start shaking, et cetera). I have uninstalled Steam and removed all game content and that has not deleted the icon.

I have also deleted the "Application Support" folder to try and force the Launchpad to reset itself; it did reset, but the icon stayed there. There is also not an icon in the Application folder for the game, or Steam (now that I've removed it).

Does anyone know how to correct this issue?

2 Answers 2


Steam creates “shortcut” applications in the Applications folder in your home folder, not the system-wide one. Unfortunately, it does not delete them when you delete a game, but you can delete them yourself; the path is /Users/[your account’s short name]/Applications, as shown in this screenshot.
enter image description here
Should you wish to recreate one of these, right-click on the game in Steam and choose “Create Desktop Shortcut”, then move the result from your desktop to your Applications folder. (This can be useful to restore a missing icon, though it only works sometimes for that.)

  • On a side note, the "only works sometimes for that" for desktop icons is the same situation as on Windows. I've had it lose the icon for HL2 of all things on Windows before, and that didn't fix it. :/
    – user2974
    Dec 30, 2011 at 7:35

You have to go to Finder > Macintosh HD (or whatever hard drive you have) > Users > your username > applications and it should be there. For some reason this application folder is different then the standard and thats where mine was put. This worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .