I can't get achievements in this game, also the Steam In-game function doesn't work. May this problem related to the fact that the game is in Flash? Anyone has the same problem?

  • 3
    Is this in Windows or OSX? Because currently the game's achievements will not work in OSX (and support is not planned at this time). – Crag Jan 4 '12 at 17:22
  • Do you mean that you can't get achievements at all, or that they simply don't pop up, as per agent86's answer? – Aubergine Jan 4 '12 at 18:03
  • This in Windows. The achievements simply don't pop-up, so in my profile I have 0 achievements, when actually I have the most of them. Sorry for not being specificy in the question above. – unil Jan 5 '12 at 10:52
  • Thanks for the answer, Crag. Guess it just sucks to be a mac user, buying games that are partially supported and they don't even think it's worth it to tell you. – octern Oct 21 '12 at 17:30

In Windows, the FlashAchievements.exe that ships with the game is broken for many people. I've contacted Edmund with information about a fix, not sure when that's going out but he says he's working on it after this update goes out, in the meantime the fix on this page works:


You want the 1.5 version, the second link to a zip on that page. This is for windows, on the Mac there's nothing at present.

  • 1
    Weird, I've never had a problem with the achievements (on Windows). – a cat Jan 4 '12 at 18:02
  • I was having the same problem, and the file on that link fixed it for me. – Niro Jan 4 '12 at 18:38
  • lunboks, just edited the answer to say broken for many people instead of just broken. – Kurt Koller Jan 4 '12 at 19:58
  • The fix worked well, thanks! Is there a fix for the in-game issue? (I checked: the option "in-game" is activated in the proprieties of the game). – unil Jan 5 '12 at 15:38
  • you can't being up the overlay because it's a flash game. I don't think there's any way around that. – Kurt Koller Jan 5 '12 at 15:57

If you're paranoid like me and don't want to download things from the internet that you're not sure where they come from something that works for me is this:

I unlock some stuff and finish my run (steam has not registered any achievements). Shut the game off. Go into Isaac folder in the steam tree and remove FlashAchievements.exe. Go into Steam, verify integrity of files, Steam notices FlashAchievements.exe is missing and downloads it. Start the game up and get the achievements.

The annoying this is that this has to be done each time the game is started up, i.e. this works the time the game is started right after verifying and getting FlashAchievements.

That said; well done on fixing the issue InsidiousForce.


When I was trying to get the Krampus achievement, I noticed this as well. The achievement popped fine in Steam, but the overlay wasn't really working properly. I wanted to take some screenshots for my answer, but I wasn't able to do that either.

Some people were able to fix this by upgrading to the latest flash client, however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.