Every game I try in my Nintendo Entertainment System just flashes the red power LED on and off and never sends a signal to the TV. I've tried inserting several different games. I've tried inserting them in all the way or just barely enough to push down. I've cleaned the cartridges as best as I can (mostly blowing really hard). Can I fix this problem or should I retire the trusty old friend?


7 Answers 7


This is due to a poor connection between the cartridge's contacts and the pin connectors. There are a few fixes for the problem:

  • Use rubbing alcohol with a cotton swab on the cartridge's contacts.
  • Try turning on the system without pushing the cart down into the NES. Just insert the cart so it connects into the slot, but leave the door open and don't push it downwards.
  • Lastly, you can replace your pin connector. It requires opening the system up, but it is a relatively painless process, and you can get replacement 72 pin connectors dirt cheap on ebay. There is a good tutorial for it here: http://www.jandar.net/nes72pin/
  • It looks like that link to the tutorial is broken (makes sense since it's been awhile); are there any other good tutorials that could be substituted instead?
    – risingTide
    Jun 1, 2019 at 3:06

If you're not able to repair it and don't want to go the emulator route, you can buy new Nintendo-compatible hardware such as the FC Super Loader or this one from ThinkGeek. The FC in particular takes NES controllers as well as games; a couple of my family members have it and have been happy with it.


The trick I always used was to fully insert the cartridge, then try to power up. If you get the blinking, turn the power back off, pull the cartridge out slighty (1/8 inch or less), then try powering up again.

Repeat this process until the game works, or until you're frustrated enough to go buy a Rumblepad 2 and download FCEUX.

  • 1
    Hehe, I agree with the slight pull-out method. I have found strange results with an NES that has a bad connection. Sometimes pulling the cartridge out a tiny bit helps, other times actually releasing the lock (where the cartridge is up) worked. :|
    – Synetech
    Nov 22, 2010 at 20:16

It could be that the console itself is dusty.

Try blowing into the cartridge slot, maybe that will help.

Or you could open it up and clean it, but if you do, be careful so you don't damage anything inside it.

  • I'm not sure it's possible to damage a NES. I've seen one get thrown into a wall as hard as the (adult) thrower could and continue functioning perfectly.
    – Fambida
    Oct 6, 2011 at 4:28

It is likely a bad connection between the cartridge's edge connector and the slot connector inside the console. Start by using a cotton swab with a bit of rubbing alcohol to wipe off any patina that has accrued on the edge connector of the cartridge. If that doesn't help, try doing the same thing with the console's connector (if it's not a top-loading console, you'll need an extra long swab).

Standard pencil erasers are usually great for wiping off patinas from electronic connectors, but they are extremely hard to use on the connectors involved here (they are better for things like computer RAM).

If all else fails, I have had some success by using an emery board (one of the cheap cardboard nail files that come in packs of a dozen) to scrape off the patina from the connector of the console.



Another option (though it takes some skill) is to disable the NES10 lockout chip, as that is the component that actually causes this problem.

See https://en.wikipedia.org/wiki/Nintendo_Entertainment_System#Lockout (3rd paragraph) and



Try to press the reset button multiple times fairly quickly while the light is flashing and see if you can get the light to stay on / a picture on your TV.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .