5

I've completed the Thieves Guild main questline (Darkness Returns) and chosen my special power (Shadowcloak of Nocturnal). It says completed in my quest log.

I also completed the extra jobs in each city you can give Thieves guild influence to (Markarth, Whiterun, Windhelm, and Solitude) and done their special jobs from Delvin. They show completed in my quest log. I've even done at least one of each kind of job from Vex and Delvin (but not in each city).

I got 4 vendors in the Ragged Flagon and have done the quest for Tonilia (delivering the Moon Sugar to a caravan) and Vekel (getting the 4 books). I've also upgrade one of my pieces of Thief Armor.

I talk to Brynjolf to become guild master and I get no dialogue options but he just says he's busy and we'll talk another time. There is a guild chest in front of his desk but it's locked and I don't have the key.

What am I missing? Is there some bug I've encountered?

  • are you playing on the PC by any chance? – l I Jan 12 '12 at 22:04
  • Pc indeed. Console commands are an option. – Dycker Jan 12 '12 at 23:15
  • there you go, console command is available :) – l I Jan 13 '12 at 2:03
6

It seems indeed that there is a bug related to thieves guild leadership:

If the player completes the main story arc before doing the side and improvement quests for Vex and Delvin, Brynjolf may not interact with the player and instead repeat that he is busy and that he will talk to you later. Consequently, becoming the Guildmaster will be rendered impossible. This may be a part of a bug where Karliah disappears and does not appear in either the Nightingale Hall or the Twilight Sepulcher. She does, however, return to the Snow Veil Sanctum where you first encounter her.

Possible Fix:

Run outside when finishing your first interaction with Brynjolf. You need to run outside as quick as possible by going to the ladder and exiting. You should see the quest update pop up reading: "Started Under New Management". Afterward, go back inside and proceed to Brynjolf. To talk to Brynjolf, let him go to the middle of the Cistern first, and wait. He then should start talking to you, finishing the quest. If this does not resolve the issue, it may be worth it to try attacking them, paying the reparations, and trying again.

Another possible fix is to get the quest about fixing debt from the guy at the Riften stables. The player will be told to talk to Sapphire. Instead, Sapphire should be sitting on the bridge just inside Riften and when approached will say "I don't have any business with you." or "We'll talk after the ceremony." Attack her 3 times, and this should cause her to start attacking the player notifying them that "Under New Management" has been completed and that the player should talk to Brynjolf. Upon entering The Ragged Flagon, the player will be required to pay 1000 gold to Vex as reparations for killing a fellow Thieves Guild member. After doing so, speak with Brynjolf and the questline SHOULD be completed.

As a last resort, you can use the console to fix this issue:

setStage TGLeadership 0

  • Talked to Karliah, I had 2 unchecked conversation options but still hasn't affected anything yet. Brynolf (and Vex who tells you to talk to him) remains unchanged. – Dycker Jan 12 '12 at 19:59
  • It worked! I used the console command, stood in the center (waited 1 hour to force Brynjolf to start the ceremony) and quest done. Thank you! – Dycker Jan 13 '12 at 17:51
2

Brynjolf had kept on telling me that he was too busy to speak to me even after I finished the 4 special quests. I finished out the quest for the barkeep and I finished the job for the fence at the guild and then when I went back to talk to Vex she told me that Brynjolf was looking for me. Don't know if its related at all but it didn't happen instantly after finishing up the specials.

Do you see all 4 new vendors in guild across from the bar? Maybe one of the special quests is hung up,despite what it says.

2

Did you get all the special items for Del? You have to get of them first before you can become the guild leader.

1

Since you consoled your way just a note to avoid it altogether IMO.

Delivering Arondil's journal to Vekel is a HUGE bug. Even after the latest patch, the journals do not leave your inventory, and you get nothing in return.

I have been affected by your bug, been bitten, and stay away from it in subsequent playthroughs. I always do that quest last AFTER becoming Guild Master. I do talk to Vekel and get it in my quest log though. YMMV

1

Brynjolf kept telling me he was too busy, I'd finished the four special jobs, did the barkeeps job, and the caravan job, still nothing. I finished returning the skeleton key, still nothing. I had already done debt quest very early on, so couldn't use that fix, and I'm playing on the xbox so can't use console commands. But I fixed it. I did one more job for Delvin, a fishing job, and wore my full set of theives guild armor when I turned it in. As I walked past Brynjolf, he said good to see your in one peice. I came back and talked to him and Under New Management started.

0

This answer is more for a different question that was wrongly marked as a duplicate of this one, and therefore cannot be answered. In the other question, the asker said that he did the returning the key quest, and returned to the guild to try to become the guildmaster. Brynjolf did not show up for him for several days (in-game), and when he finally did show up he was wearing the guildmaster armour. His only dialogue option was to ask how the guild was doing, to which the response was "Better now that Mercer is gone." This, I believe, is a totally different bug that I personally have encountered a couple times. Occasionally, Karliah and Brynjolf ask you to become guildmaster before you choose your Agent in the Twilight Sepulcher, but then Nocturnal speaks to you, which takes your attention away from the other two as though you just exited the dialogue. The game seems to register this as you declining the offer, so Brynjolf becomes guildmaster instead. I have no actual source I can quote here, just past experiences that led me to form my own theory of what went wrong for him. As I said, this answer is not actually intended to help here, although it could be a similar bug. I don't know any fixes for this, besides reloading a previous save or console commands, although the asker of the other question stated that he had already tried all the solutions listed above in the other answers on this question, and none worked.

protected by Community Nov 23 '12 at 21:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.