I recently downloaded AirMech, but when I try to run it, Iron(Chrome) says, "No plug-in available to display this content." What plug-in do I need?

I can confirm that I'm able to view other things using Flash, Java, Unity, HTML5, and Shockwave. I also have the latest version of Iron.

  • any chance you are running no script or some other ad blocking mechanism?
    – l I
    Jan 13, 2012 at 23:22
  • @yx.: It's Iron so it comes with AdBlock, but I don't use it much, so there's a good chance I'm missing a plug-in. Jan 13, 2012 at 23:24
  • hmm... my guess would be flash. According to this thread you can use the same flash plugin that chrome uses.
    – l I
    Jan 13, 2012 at 23:25
  • @yx.: No, flash works fine. Jan 13, 2012 at 23:28
  • You could always apply for the actual alpha.
    – GnomeSlice
    Jan 13, 2012 at 23:52

1 Answer 1


Just looked through an article about it and it suggested you do these three things:

  1. Use Chrome. Chromium may have issues with Native Client
  2. Type chrome://flags in address bar and enable Override software rendering list (browser restart required)
  3. Native Client is enabled in chrome://flags

I may have to take a look at this. Looks like it's built on the Spring engine.

  • hmm, nope, didn't work; I'm still getting the same error. Jan 13, 2012 at 23:44
  • Hm. I don't actually use Chrome, so I can't do any testing on my end.
    – SaintWacko
    Jan 14, 2012 at 1:56
  • Yeah, I asked on their site, and the developer said it only works with Chrome. I tried that and now it works. Jan 14, 2012 at 3:55

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .