I've been playing Skyrim for a few months without issue -- character is level 38.

Suddenly, today, I'm getting very frequent crashes to desktop -- usually when I'm in major cities. Often just after fast travelling, but can also happen while I'm running/sprinting through town. It may not be related by my sprint function (ALT) has gotten a little sticky-glitchy today, too.

I've tried lowering various setting (shadows, anti-aliasing, etc). Seemed to help a little but not much -- or that may have been coincidence. Screen resolution is at the lowest setting. I read on other fora that sometimes the size of individual game files could be problematic, if they're near 18MB -- mine are all under 10MB (though I tried the sleep-for-7-days fix that was recommended to help that, just in case). I've read that some mods can be problematic, but I'm only running one small mod -- the one that make veils of ore glow, so you can spot them easily -- and the problem never happens when I'm out in the wilderness near ore veils, so I think it's unrelated.

Anyone? Anything? I'd be very grateful for any suggestions. Ideally couched in human-speak, rather than computer-speak ... I'm only semi-computer literate.

  • At least it's not blue screening (that happened to me the first time I played it). The fact that it's happening with the lowest resolution sounds troubling though.
    – MBraedley
    Jan 15, 2012 at 0:23
  • Yes, it's a problem. I was having issues when I first started playing, a couple of months ago, but dropping the resolution fixed it. But blue-screen would definitely be worse!
    – Elizabeth
    Jan 15, 2012 at 3:39
  • try lowering your character view distance to the minimum, see if that does anything
    – l I
    Jan 15, 2012 at 4:35
  • 2
    Have you recently updated your video drivers? That could be the issue. Feb 24, 2012 at 15:53
  • 1
    Could be unrelated but just a thought, how hot does your processor/video card get? Make sure your power supply has enough power for your video card too or it'll eventually give out completely.
    – Hydlide
    Apr 5, 2012 at 0:29

3 Answers 3


Try removing the only mod (the "glowing ore veins mod") you have, just to check if does not really cause the crashes.

Also, it might be the case of the ol' Savegame bloating. Install the Unofficial Skyrim Patch (USKP) (original / Legendary Edition - PC) / (Special Edition - PC) / (PS4 / PS5) / (Xbox One / Xbox Series X/S). Among its fixes are:

  • NPCs will no longer drop weapons or shields as separate objects, as these are never cleaned up which greatly adds to save bloating and litters the game world (the items will still appear to be dropped, but will access the corpse's inventory to be taken and be cleaned up with the corpse if left)
  • Ghostly Remains, Ice Piles and Wisp Cores will no longer permanently remain and bloat the save file (they will either disappear on exit of the cell or when the cell resets)
  • The torches on sconce activators will no longer duplicate-in-place (also adding slightly to bloat) when their cells respawn; the duplicate(s) would remain when the player picked up the newest torch (note that this fix is not retroactive for existing duplicate torches; simply open the console, click any duplicate torch and enter delete to get rid of it and no new ones will appear)

The USKP is a comprehensive Skyrim bug-fixing mod that could also help solve other potential CTD issues. Full list of its fixes here.

The mod, Possessive Corpses (PC original / Legendary Edition), has a "less arrows" module, which has this feature:

The amount of arrows per cell (not counting the ones in inventories, droped or attached to actors has been reduced from 15 to 5.

From the mod's description:

Missed arrows aren't deleted by the game, but there is a max number of arrows allowed in the world. Once you (or another actor) fires an arrow pass that limit, the first one being generated is removed. This way, arrows can last months but won't ever pass the limit number. In my game that number is 15, but Those of you with ultra settings may have a greater number (I really don't know what controls this number and if can be changed at all).

I'd use only the 'less arrows' module of Possessive Corpses with UKSP (as the other features of Possessive Corpses might overlap with UKSP).


I had a somewhat similar problem.. It was resolved when I deleted a few older save-states. Try deleting your older saves [if you have multiple].

Also, be sure to have your Skyrim patched. They just released a beta patch 1.4 which is suppose to resolve graphical issues [if that is the source of your crashes].


All you need to do is delete some old saves of yours. Just delete the ones that you think you will not need again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .