4

When I host the game my friend can’t connect to me.

Our IP addresses are 192.168.1.100 and 192.168.1.101.

When I run a second instance of Game.exe I can connect myself without any issues.

Both computers have Windows 7.

I tried to find some information on Google to configure Windows. There was advice to remove IPv6 protocol, but it doesn’t help.

5
  • Are you on the same local network?
    – ver
    Jan 15, 2012 at 12:29
  • Yes, and I have similar trouble with Warcraft3 Jan 15, 2012 at 14:07
  • turn off your firewall?
    – l I
    Jan 15, 2012 at 14:11
  • 2
    Can the two computers communicate over tcp/ip at all? Can you successfully excute ping commands from each of them to the respective other? Jan 15, 2012 at 14:17
  • yes, ping works Jan 17, 2012 at 17:58

3 Answers 3

4

Since the two computers are on the same local network, as you confirmed, it might be an issue of either network configuration in general or firewall configuration on at least one of the machines.

There is a support article on Battle Net about neccessary tcp and udp ports for Diablo2. I suggest to look it through, but the core info is:

Diablo II/Lord of Destruction: TCP Port 6112 and Port 4000.

4

While, for security reasons, I wouldn't recommend disabling your Windows Firewall completely, it might help in diagnosing the issue. This article will help you disable it and in either event enable it again. It's also possible either an intermediate router or an additional piece of virus scanning software may be imposing yet another firewall.

0

Windows 7 has a feature called "Remote Differential Compression" that is enabled by default. This can cause issues with old games when playing on a LAN and possibly in other network instances with games. It can be uninstalled by going through the Control panel/Programs_uninstall a program/ and clicking on the link "Turn Windows Features on or off". Then you can uncheck the box.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .