As the title says, I'm having huge problems with the "Blood on the Ice" questline. On my first playthrough, I was able to finish the quest withouth problems, was able to buy, clean-up and furnish the house, but on the second playthrough, this questline is utterly broken, and I dont know why.

Quest triggered normally (walked into the graveyard at night), and I was able to persue it until the point where I had to investigate Hjerim. I talked to Tova Shatter-Shield, got the key and entered Hjerim. Inside I found the usual mess. Bones, blood, etc. The Quest updates to "find the clues". And this, I think, is the point where my quest broke for some reason I cannot fathom. Whenever I want to investigate ("Use") something inside Hjerim, nothing happens. I tried to use the chest, the bed, the little shelf with the amulet and the fliers and the "false" cabinet. But nothing happens. I'm not able to open the cabinet, I'm not able to pick up the amulet or the fliers. Also, instead of "Investigate Bed" for example, it says "Investigate InvestigationTarget".

I got desperate, so I tried to jumpstart the questline by putting a flier in my pocket via a console command. The quest updated, and I went to find Viola Giordano. Once I found her, she came with me to Hjerim, to investigate further. She stopped next to the false cabinet and told me, that it looked unusual, and that I should investigate it. BUT I still cannot interact with it. I cant open it, and I'm stuck.

I also tried to finish the whole questline via console, bought the house, cleaned up the mess, furnished it, but I still cant open the false cabinet in order to get access to the alchemy/enchanting lab. I just dont know what to do anymore, since I cant find anything on the internet about this particular situation.

I hope someone can help me. Hjerim is the one house in the game with the most storage place, and I really wanna have it (working).

2 Answers 2


If the killer was killed by something it does this, say a dragon attacked at some point, and killed the person who turned out to be the killer. That would be your answer to why it is screwing up. Or at least that was the answer when this happened to me. I just reloaded afterward.


Blood on the Ice is one of the most bugged quests in Skyrim. You might need to make another save and try from that save, but it might take a while.

I can't buy the house most likely because I am a part of the dark brotherhood, but on the other side I had before it was lost, I killed the members and bought the house easy as cake.

Are you a member of the dark brotherhood? If not, you might need to start to another save.

  • It's still possible if you're in the Dark Brotherhood you just need to kill Nilsine.
    – Jim
    Oct 13, 2015 at 3:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .