I tried to open my SWTOR Launcher this morning after turning my computer back on (played last night just fine) and the launcher won't open. The process is running (launcher.exe on the task manager) but the window never shows up. The log file in

Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic\logs

says this

[datetime] Failed to load bundles
[datetime] Going offline

What gives?

1 Answer 1


Alright, I read what seemed like dozens and dozens of forum posts on how to fix this problem and nothing was working (this seems to be a rather large problem and has been since beta). I tried using the FixLauncher.exe, didn't work. I tried running the SWTOR_setup.exe and reset to defaults, didn't work. I was about ready to give up and just uninstall and reinstall the entire game but I got lucky.

This is what finally got the launcher to show back up.

  1. Navigate to Program Files (x86)\Electronic Arts\BioWare\Star Wars - The Old Republic and delete the Patch folder
  2. Restart the computer
  3. Run FixLauncher.exe
  4. Restart the computer
  5. Run launcher.exe
  6. Wait for the launcher to update and restart itself

This probably isn't the only fix to this but this is what worked for me.

If you want to look through the "This isn't our fault (even though the launcher is so bad we actually have a FixLauncher.exe), so how about we start at the beginning and kill some time... while we try and fix the launcher" - Troubleshooting Guide - There you go.

  • I've had this happen, but all I've done is kill the process that was still running and it worked after. If you don't know how to kill a process reboot windows. If this does NOT fix it, then it's a different one then I encountered.
    – Viper_Sb
    Commented Feb 7, 2012 at 15:28
  • @Viper_Sb Oh believe me... I tried killing the process multiple times. The "Failed to Load Bundles" problem has been around for a while now, and there doesn't appear to be a permanent fix coming any time soon.
    – Adanion
    Commented Feb 7, 2012 at 15:40
  • @ Adanion ok then I ran into a similar problem but was fixable by killing it. good to know.
    – Viper_Sb
    Commented Feb 7, 2012 at 16:17
  • Thanks Adanion. Your solution worked for me even without restarting the computer. i just had to kill the launcher process from the task manager for the FixLauncher app to work. (the important part was to delete the patch folder)
    – Rodik
    Commented Mar 11, 2012 at 17:49
  • I just ran into this and it was a real pain to resolve. But this answer helped. I didn't need the reboots. But deleting the patch/ folder, killing the launcher process, and starting it again did appear to solve the problem.
    – Splaktar
    Commented Dec 5, 2020 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .