6

I installed a game called Peggle Extreme, a free game in the Steam web store, but when I tried to play it, it gave me an error:

Unable to load Steam.dll

  • I do not have this issue with any other games.
  • I tried uninstalling and reinstalling the game, but to no avail; I still get the same error.
  • As far as I am aware, it has fully downloaded and ready to launch.

I was wondering if this is a widespread issue, or if it is just me.

I have attached a screenshot: Steam Screenshot of Error

  • I had this issue before and emailed Steam Support, who instructed me to reinstall Steam (which worked). – victoriah Feb 6 '12 at 8:45
  • Hmm but I have so many GB (like more than 50GB) of games installed! Would I have to re-download everything? – gameaddict Feb 7 '12 at 2:12
  • @gameaddict Nope! I'll update my answer. – ver Feb 7 '12 at 16:32
2

It seems copying the Steam.dll into the game folder might help. Source: Steam forum.

Edit: In the comments, someone mentioned you should reinstalling Steam. If you choose to try that, don't forget Steam lets you back up your games. (In the menu, select Steam > Backup and Restore Games)
If you do that, you won't have to re-download all the games again.

  • What the hell, Backup and Restore games? Not necessary at all! Just move the userdata and steamapps folder somewhere and move it back in once you reinstalled with steam closed. Done. The backup function is a unnecessary waste of time in this case. – user28015 Aug 3 '14 at 22:45
2

I have deleted "steamservice.exe" file under bin directory and it has fixed. I have catched it from bootstrap_log file under the steam directory.

[2014-08-04 00:04:57] BCommitUpdatedFiles: failed to rename package\tmp.\bin\steamservice.exe_ -> ./bin/steamservice.exe (error 6800)

  • had same error in my log files. Steam installer couldnt overwrite this file, so delete it before starting steam solve the Issue. Its only work with steam client that wont launch. and might not for games that wont launch – MiniScalope Apr 25 '15 at 11:48
1

I think this is the easiest and best way to solve this from a security perspective. Edit your system PATH variable to include the directory where the Steam.dll is located.

Directions are for Windows 10. First, find "Steam.dll" on your PC (you may need to searchif you don't know)

  • On the start menu, type "PATH"
  • Choose "Edit the system environment variables"
  • Click the "environment variables" button at the bottom of the window Click on "path" and then click "edit". I personally changed the System path variable instead of the user path variable so it would be effective for anyone that logs onto the computer.
  • Click "New" to add an entry on the list.
  • Input the filepath where Steam.dll actually exists.
  • Click OK until all of the windows are closed.
  • Reboot. The game should now work.

The other answers may solve the problem, but the root cause is that some older Steam games assume Steam will be installed in the default location.

  • Copying the DLL somewhere else would likely work, but then that other copy of the DLL would never be updated unless you do it again manually. This is probably not a real problem with older games, but could potentially cause security issues since it would not get patched.
  • Reinstalling steam might solve the problem because if you don't change the defaults when you reinstall, then steam.dll would be where the program expects.
0

I had named the steam folder something different. I took a guess and tried this:

  1. In Program Files (x86), I made a folder called "Steam" (where the other Steam folder was located which I had named differently during install)
  2. Copied Steam.dll into that folder

It worked!

Here's a screenshot of what I did to fix it:

Screenshot Steam DLL Fix

0

This was enough to solve the problem for me

  1. exit steam
  2. log out of Windows
  3. log back in

I'm guessing something got stuck with a locked file during update

-2

Download new steam.dll file and replace it with old one which will be located in the application folder. Then open the .ini file and edit the value of "SteamDll" with new steam.dll path.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.