I am trying to change my companion to essential so they don't keep dying on me. However, the console command is not working for some reason.

The code:

setessential <baseID> 1

should work (it has worked before with others), but when I type

isessential <baseID>

it comes back to 0. I can confirm it's not working, because my follower is still dying, which would not happen if they were essential.

Why is it not working? What am I doing wrong?

2 Answers 2


From http://uesp.net/wiki/Skyrim:Console#Targeted_Commands :

Usage of the 'setessential' console command is: setessential <base ID> <1/0> - set a character (NPC) as immortal (1) or mortal (0).

Note that the base ID and not the ref ID must be used. The ref ID is what appears when clicking on an object with the console open. To find an NPC's base ID, however, you can either a) browse to their respective page (see: People and/or NPCs) or b) use the help function in-game to search for them by name, recording whatever value matches their name under the "NPC_" category of result. Once you have the base ID, enter the command using either 1 to set him/her immortal or 0 to set him/her mortal. For example, setessential a2c8e 1 would set Lydia as immortal.

  • 2
    sorry, I was actually using the baseID not refID, I typed the wrong one in the description. Fixed it. The solution is that you have to make sure nothing is selected before typing this.
    – gameaddict
    Feb 13, 2012 at 7:00

I discovered that if I have them selected, and do this, then it doesn't work. However, if I make sure that nothing is selected, then if works. What I mean, is, in the console, when you have something selected, you can see the refID. If you can see any refID, then setessential will not work. It works if you have nothing selected.

  • 1
    Man, I'm glad this was here. This was exactly my problem. The console is kind enough to tell you when you aren't using a base ID, however, when you use a base id, but have the character selected, the console doesn't help at all.
    – mawcsco
    Nov 17, 2015 at 23:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .