Basically I am having the same problem as described in this thread .

My connection drops every time I want to search servers in the "Internet" tab but fine if I view servers in "History" or "Favorites" tabs.

Unfortunately my router may also suffer from the overflow problem (not sure how to check) and updating firmware/open ports doesn't help (buggy router known for having port forwarding problems)

So is there any way I could limit the amount of servers the steam client retrieve to prevent the overflow problem?

2 Answers 2


In Steam, go to the menu on the top left and look for the settings menu entry.

Within the new window that pops up, look for in-game.

You will see this:

in-game settings screenshot

On this screen you can define how often Steam is pinging servers when looking them up. A slightly lower value might improve your experience drastically, as mentioned on the screenshot.

However, this only works for games that utilize either the source engine or the Steamworks infrastructure for their servers. It won't work for other games.

  • 1
    Just a note, at the time of writing this, your Steam Settings dialog might look slightly different as I am using the Steam Client Beta. This setting does exist in the normal official Version of Steam right now though. The dialog just looks different. Commented Dec 21, 2013 at 11:35

Have you got a firewall running? I found that turning off my router's firewall and on my own machine's firewall (end-to-end) is the best way to improve performance in finding/playing games. I was having issues finding MW2 and CS games with the firewall on, but now I don't have any more problems.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .