6

I've installed Skyrim and registered it with steam. I've tried to run it through steam, from the setup.exe in the disk and the TESV.exe in my steamapps folder but every time it tried to install the game again, then fails.

If Steam is closed, and I try via the disk, it loads the splash screen with an option to run the game but shortly after it just pops up with the install skyrim splash screen.

Why is this happening? How can I get around it?


Edit the First

So I've tried to follow the advice here and renamed my folder (called VCredist) which just causes Steam to tell me that skyrim may not have synced with the cloud correctly. I've tried renaming installscript.vdf which also does nothing. I've got Kaspersky running, and have had to (due to unrelated shennanigans) rename my steam folder steampowered, which is the only remaining thing that might have caused an issue. Would any of these caused the issue? Of do you think my DVD is broken?


Edit the Second.

Verified my Skyrim files, Uninstalled Skyrim. Uninstalled Steam. Reinstalled Skyrim from disc, letting it install steam in the process. Let it update. Still have the same issue. Will call steam/bethseda today.

Edit the third.

Here is what the splash screen looks like. Does it give anyone a cluse as to what's wrong? The 'install' button seems wrong.

enter image description here

10
  • 2
    That is rather strange. Have you tried backup up Skyrim, deleting the game and restoring it from the backup?
    – kotekzot
    Commented Feb 20, 2012 at 12:48
  • When you say let it update. Do you mean Skyrim, Steam or Both? Skyrim will need to update before playing it.
    – IAmGroot
    Commented Feb 29, 2012 at 7:29
  • @Doomsknight I think both updated. Steam certainly did. How can I check skyrim is up todate? Commented Feb 29, 2012 at 7:57
  • @Pureferret It should show a downloading status at the bottom of steam when viewing the library, showing the current progress of the download(update). Alternatively, Usually clicking a game that is not up-to-date, it will start the update, and show an ETA message til game is playable. Looking at your 3rd update though, it is a bit baffling. You shouldnt get to the splash screen (via steam) if the game wasnt up to date. Verifying cache should also initialise an update. There must be something else going wrong.
    – IAmGroot
    Commented Feb 29, 2012 at 9:58
  • @Doomsknight It is up to date now. What else might be wrong? Commented Feb 29, 2012 at 19:08

6 Answers 6

5

The only thing that worked was for me to reinstall Windows (!) and then reinstall Steam and Skyrim. The next step that the Bethseda Tech support suggested was to create a new user account, but like I said I skipped that and did a fresh install.

2
  • I have people not wanting to upgrade from xp and you just reinstall to make skyrim run? +1 if only i could up more.
    – Reaces
    Commented Mar 31, 2015 at 6:42
  • @Reaces Well, Skyrim is love. Skyrim is life. Commented Mar 31, 2015 at 7:17
1

My initial suggestion was to run TESV.exe but you've already done that. I'm not sure what is happening here it's rather strange but I have heard of this issue before. The only thing you can try is to backup your save files, delete local content and re-install Skyrim. This should fix it for you.

2
  • 2
    Good thing I don't have save files as I haven't played skyrim yet! Commented Feb 20, 2012 at 22:57
  • I uninstalled (which deleted all local content) then reinstalled it, but no effect. Commented Feb 21, 2012 at 9:06
1

I had this same problem.

Instead of running the setup from the disk, open Steam and click the 'Steam' button on the top tab. Choose 'Backup and Restore games' and select the backup location as the disk. This should install the game from the disk without any problem.

If this doesn't work, then your disk is probably corrupted.

3
  • When I try this, I get to the validation window again, and it validates. Then I have the same issue again. Commented Feb 29, 2012 at 8:34
  • Try setting Compatibility Mode to different OS's for the steam executable. This helped me when I had validation problems. Commented Feb 29, 2012 at 8:57
  • I have no issue with the validation, that works, it just doesn't do anything else. Commented Feb 29, 2012 at 19:08
0

Steam reads its install status from an installscript.vdf file in the game's steamapps directory. You can try deleting that (after a backup, of course).

Shot in the dark, though.

3
  • After I delete it, it creates a new one and I get back to where I am to start Commented Feb 26, 2012 at 8:20
  • You've got to close steam, delete it, and then reopen Steam, for the record. Ah well, was worth a shot. Commented Feb 26, 2012 at 12:34
  • That's what I did. Never mind. Will try uninstalling steam next... Commented Feb 26, 2012 at 13:11
0

I had this problem on my home user account but when I log onto another user account I can play Skyrim just fine. Try using another user account.

2
  • This was actually the next step Bethseda suggested. I'm not sure if it would have worked though. Commented Aug 17, 2013 at 22:44
  • This sounds most puzzling.
    – SamB
    Commented Feb 3, 2016 at 19:02
-1

Check the skyrim folder for a folder named "redist." This is for directx etc. Try renaming that folder to something like redist_BAK.

1
  • Unfortunately this doesn't work. Why should this work? Commented Feb 26, 2012 at 8:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .