I can't get Blood on the Ice to start, no matter what I try. I did kill Nilsine for Dark Brotherhood, and now people talk about murders but there is no dialog option with anyone for me to help. I tried Jorlief, Viola, the wizard, and Nilsine's father. Got the key from her mother's body (suicide), went into Hjerim and got all the pamphlets, journals and amulet, but the quest never started. Help!

Also, I started a new game, and got the quest started and finished no problem! But I'd really like it in my main game.

  • The quest is started by the guard standing over a dead bovy at the Windhelm graveyard. Does she refuse to talk, or is the scene missing entirely?
    – kotekzot
    Commented Feb 23, 2012 at 11:42

6 Answers 6


I'll save you some time here.

You can't complete it. I did pretty much the same thing -- killed Nilsine, got access to Hjerim with the key from Torva, etc. -- and have never been able to start the quest with that character.

I have reset the Windhelm visit count then returned several times at the right time of day. I have used console commands to start and end the quest, both inside and outside the city. I've tried resetting game days (after 245 days Susanna's body disappears), resurrecting the body, resetting my level and leveling up once, entering Windhelm from every angle and time of day, talked to Viola and Jorleif, and tried it at every stage of the Stormcloaks questline. I've picked up everything, found every journal, tried to investigate every InvestigationTarget. Nothing. It's just bugged.

If someone has found a magical console command, go ahead and share it. But I'll take it from the massive amount of discussion without resolution that no one has.

I hate to be the bearer of bad news. It would be great if someone actually has a solution. But the realistic answer here is "whatever the reasons, you can't overcome them." At least as of version 1.4.


Lockpicking your way into Hjerim works.

After investigating Hjerim, and finding the amulet, talk to a guard.

I talked to the guard outside the palace of kings, so, that definitely works.


Okay, so every time I have gone to Windhelm to start the mission, it has always been Frostfall (Month). And every time I've been able to do it. It may be different for other people, but this is all I have to help.


Had same problem replaying Skyrim. The console commands given here http://elderscrolls.wikia.com/wiki/Talk:Blood_on_the_Ice made it happen for me. Starts at a quarter down the page, with the" setstage 000A7B33 10 " (youll need 12.000 for this as it will buy you the house) command. Got all the decorations now, and most of the blood is gone, though some parts of the house are still glitchy (old furniture colliding with new furniture, "investigate" options still appearing, etc).


You could always try just lockpicking the door to Hjerim. It's hard (Master) Lock but i had the problem of not being able to start the quest because their are no guards around, i picked the lock into Hjerim and as soon as i entered it started the quest.


You can't finish the quest because of the updates (dragonborn, heartfire, dawnguard) that have come out. If you delete them, it should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .