I've reached the fifth section of the Deus Ex:Human Revolution Missing Link DLC and now I can't load ANY of my DLC save files? When I select a game to load the screen goes black for a good 3 seconds, then the loading screen comes in with some lag. When I push 'A' when prompted, the screen goes back to black and the my Xbox freezes (the guide button does nothing).

I had just reached the fifth section and talked to Keitner about the gas, I tried to kill the guards and turn off the gas but failed miserably and could never load a save after that. I am aware of the game freezing just before this point. I want to stress that I did not have that problem.

Does anyone know a way I can load one of my saves? I've tried loading just about all 20 of my saves from the DLC. I've tried loading my 'Latest Auto-Save' as well as my 'Previous Auto-Save.' I've also tried deleting and re-downloading the Missing Link DLC... no luck.

UPDATE: I just tried moving my saves to my flash drive, didn't help.

  • Does starting a new game of the DLC help? Can you load any saves from the main game? Is the main game installed to the hard drive? If so, have you tried deleting it and running off the disc or reinstalling it?
    – Adeese
    Commented Feb 29, 2012 at 3:13
  • Saves from the main game load quickly. I started a new DLC, saved, loaded... it was laggy, but the game came up. I tried loading a file from the previous save again but it didn't come up. The main game wasn't installed to the HDD previously. I tried installing the main game and still couldn't get the old saves from the DLC to load.
    – Weezle
    Commented Feb 29, 2012 at 4:33

1 Answer 1


Ok, nearly a little over a year later I finally tried to get this to work again. After deleting 4 or 5 of my most recent saves from the DLC, I was able to load and play one of the earlier saves I had made during the DLC.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .