I keep getting a "The Launcher cannot query DirectX. Please update DirectX by installing the latest redistributable" error message when launching L.A. Noire.

I'm on Windows XP, and this is the Steam version of the game. GPU: NVIDIA 9800 GTX+, running 285.x drivers (the newest available for XP).

Problems started after the most recent patch (the patch that added DirectX 11 support... but I'm on XP, so whatevs).

Pre-patch, I would get the problem; the launcher would crash, but then the game would start anyway, so I didn't care, but now it doesn't launch at all. I can't downgrade retroactively (as far as I know?) because it's Steam, so I don't have the original media.

I've tried uninstalling and reinstalling DirectX, launching the game directly, launching the game as admin (I'm running as admin already, but I do "Run As" and uncheck the "protect this computer box"), launching Steam as an admin, validating the game cache, re-downloading, and reinstalling. Nothing works. I've tried disabling my anti-virus (Avast) (C:\Program Files\Steam\steamapps is already whitelisted). I tried downgrading my GFX driver to the 280.x version.

  • My idea is Get Windows 7 and download directX 11
    – user24863
    May 3, 2012 at 12:49
  • Do you have SP3 installed? And did you run the redist installers from the games folder?
    – user28015
    Jul 18, 2014 at 20:50
  • Lol this from 2yrs ago, I've had win7 installed for a while now. I've actually beaten LA Noire as well. I still have no idea why this happened, and my "solution" was to upgrade to win7.
    – GKMachine
    Jul 19, 2014 at 21:42

4 Answers 4


Most likely, Steam is trying to launch the DX11 executable of the game instead of the DX9 version. Try opening the install directory of the game(located in your "steamapps" folder), check if there's a DX9 version of the executable and try running that directly.

EDIT: You can also try running lanoire.exe directly instead of the Launcher program

  • To add to this, there are steam options you can add to the launch properties that specify things like DX9 mode. Try Right click game -> properties -> launch options. Then add /dx9
    – IAmGroot
    Mar 2, 2012 at 13:16
  • I already tried launched the .exe directly, There's only 1 .exe, and adding /dx9 to the steam launch options but that did not work. Neither did launching with /dx9 as a launch option to LANoire.exe directly (via a shortcut).
    – GKMachine
    Mar 2, 2012 at 22:06

Copy the Microsoft.net folder from C:/Windows into the LA Noire game folder and run the .exe but not the launcher. This worked for me.


Right click > Properties > Local Files > Verify Integrity of Game Cache

Verbose mode: I had the same error you did and after verifying the game cache it told me 1 file didn't pass validation and would be redownloaded. When I launched the game again it went through the "first time setup" stuff again and then the game ran fine.

  • I had the exact same error and the process I posted above fixed it. Jul 7, 2013 at 11:33
  • 1
    Although I did overlook that he had previously tried this. However, again, it worked for me so I'm leaving the answer here in case it works for others who find this question. Jul 7, 2013 at 11:34
  • Very well, I just saw this in the low quality queue and thought it's an answer to 90% of all Steam issues :-7
    – Zommuter
    Jul 7, 2013 at 11:36

If you use windows 7, you should download and install DX9.0c from this site: http://www.microsoft.com/en-US/download/details.aspx?id=35 It works ;)

  • No, always install the DirectX Version included with the game within the games folder. The problem is not DirectX itself, but DXUT, which has 40 different versions. If you linked your game to that library, you need the exact redist installer, otherwise it won't work. Look up dynamic linkage with C++ if you want to know more, but it is a very technical programming topic.
    – user28015
    Jul 18, 2014 at 20:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .