I have completed the main quest line. I have done 62 jobs for the Thieves Guild, consecutively, over the course of a few (real life) days, little by little. I have done a variety of jobs from both Vex and Devlin, and I have been given and completed THREE of the FOUR special jobs. Not a single one of my 62 jobs has been in Windhelm, and as such, that is the last remaining "special" job (Summerset Shadows), according to the wiki.

What do I do? Do I have to do something specific in Windhelm to begin getting jobs there? If I'm bugged, how do I get the achievement?

My version number is, and this is on the PC.

EDIT: Well, I've been doing it for about 2 hours since making this question. There's simply no way my luck is that bad --- the game will simply not give me Windhelm jobs. The only thing special about Windhelm is that I captured it (as I sided with the Imperials) as part of the Imperial questline.

  • 2
    Sometimes the jobs cycles if you reject them. So you can pick a job look so see if its Windhelm, if not reject it and it may cycle to the next job. I had the same problem but with Markarath.
    – Harpal
    Mar 3, 2012 at 11:48
  • Yeah when I searched for answers I read that, and tried it --- no go. Mar 3, 2012 at 11:51
  • 3
    Have you been back to Windhelm since capturing it? I wonder if there is a reset of some sort that needs to happen and you need to head over first.
    – tkott
    Mar 3, 2012 at 22:20
  • 2
    I went back to Windhelm and talked to various people. Nothing changed. Ultimately I just succumbed to console commands and jumped ahead to the completion of the fourth special job, thus giving me the achievement. Very annoyed that I couldn't do this legitimately. I'm convinced this is a bug. Maybe it's because when we went to capture Windhelm, I ran ahead and killed everything myself, leaving the Imperials in the dust. Maybe that caused me to miss some sort of "trigger" or "reset." Bleh... Mar 4, 2012 at 5:32
  • 1
    @CptSupermrkt: You should write that into an answer (including the console commands you used), in case anyone else in the future has this same problem. Mar 8, 2012 at 7:48

4 Answers 4


I finally found the solution for this today after much frustration. If you attacked Windhelm with the Imperials and killed Ulfric, but left before Tullius could leave the room and give his speech then the Thieves Guild quests for Windhelm will be bugged. Simply go back into the palace, let Tullius and Rikke leave, listen to the speech and talk to them, and then go talk to Delvin and Vex, and this fixes the bug.

  • I've long since finished Skyrim and gotten 100%, but it's nice to finally know what that was all about! Thanks. Switching to answer as Accepted. May 23, 2012 at 5:21

As I was only missing the Windhelm special job ("Summerset Shadows"), I ultimately just had to use the console command setstage TGTQ04 200 to skip to the completion of that quest.

Upon "completion" of the quest, the achievement for restoring the Thieves Guild isn't immediately awarded. You have to first talk to some of the guild members to trigger a conversation that leads to everyone recognizing you as having "restored the thieves guild." Since I used a console command, it's kind of hard to explain exactly who to talk to --- the game was obviously in an "unnatural" state by being forced forward via console. By that I mean, people were having conversations while walking, some people wouldn't acknowledge me, someone straight up walked into another zone mid-sentence. Best advice is to make a separate save and make sure everything goes smooth.


Go to Delvin or Vex and "quick save" your progress then ask for a job. If the job is not Windhelm then use the shortcut "quick load" and then ask them again until the job you want is in Windhelm. It may take a couple of minutes but eventually you'll get it since every time you do that a random city shows up.

Advanced save/reload method: At the end of the speech options your last choice is something like "I'll do it" or "Sounds easy enough". For the next bit you need to be fast on the quick-save button (F5). Instead of clicking the speech choice and waiting, you need to click the mouse on the choice several times so the screen clears faster than usual. Immediately make a quick-save before the screen shows the radiant quest details. If the quest is in the wrong city, pressing quick-load (F9) will take you back to the next selection of random radiant quests without the need to go through the speech options again. Markarth seems to be offered very rarely for some reason. I once had to reload 40 times before Markarth was selected.


Getting the necessary radiant locations to earn the "special jobs" from Delvin can be a bit annoying. You basically have 2 options: Keep completing jobs for Vex and Delvin in places you don't need to finish or, quit the quest and come back hoping for better luck. That much everyone knows, I'm sure.

This is what I learned the hard way, though. When you quit a quest from either of them, there is a chance they will literally pick your pocket as a consequence. It appears they take jewelry out of your inventory after quitting a number of quests from them. It doesn't appear to be anything equipped but, there is no value limit. On some occasions I lost a generic gold ring (smithing fodder) and on others, rings and necklaces that had high level enchants. So, be careful when attempting to finish this quest chain as it could leave you poorer than you started.

  • It just happened to me. So yeah. It happens. May 23, 2013 at 12:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .