I just finished one of the Stormcloaks missions and I am supposed to report to Ulfric. When I check the quest journal, I see that three entries are completed (Liberate Falkreath, Liberate The Reach, Liberate Hjaalmarch; Liberate The Pale is apparently the next quest and I didn't do it yet) and below them is an uncompleted "report to Ulfric Stormcloak".

I tried going to him, but he says about making me a Thane and that I should purchase the house first. So I helped five citizens, but Ulfric's advisor still says that the house is unavailable yet. And Ulfric is still marked with the quest marker, even though I just get generic speech options when I speak to him ("How is the war going?", "Why do you fight?", etc.)

I also thought about doing Blood on the Ice, but I can't trigger it. I tried entering Windhelm at midnight multiple times, but there's nothing in the graveyard. Also note that the waitress is still alive in the inn, so I don't think that I missed it.

I'm before speaking to Paarthurnax in the main quest line.

UPDATE: I am past the first fight with Alduin and the next quest was The Fallen, suggesting that Season Unending was skipped. Is this correct?

UPDATE2: Finished Dragonslayer. No change in Stormcloak quest.


2 Answers 2


Try going to one of the Stormcloak camps you've recently been to and talk to Galmar Stone-Fist. He is usually in the palace with Ulfric, but during the liberations he's at camps near the place you're liberating.


This is a known bug. From the Unofficial Skyrim patch page on this:

I’ve run into an issue where I simply cannot get the Blood on the Ice quest to trigger. I’ve tried countless fixes to no avail. This is the quest that needs to be completed in order to obtain the house in Windhelm.

Status: Verified

What is the version of Skyrim you're playing? Depending on the version, there are known events that could trigger this bug:

  • If you capture Windhelm for the Imperials before you start the quest, the witnesses will be around the corpse but the guard may not be (since the Windhelm guards have been replaced by Imperial Legion soldiers), making it impossible to start the quest. (This bug is fixed by version 1.4 of the Official Skyrim Patch.)

  • If Viola has died for some reason the quest may not start or will be impossible to finish. (This bug is fixed by version 1.5 of the Official Skyrim Patch.)

There are more bugs and other possible solutions on this UESP 'Blood on the Ice' discussion page: http://uesp.net/wiki/Skyrim_talk:Blood_on_the_Ice

What platform are you playing on? This discussion thread from the above UESP 'Blood on the Ice' discussion page describes a method (console commands - PC only) to be able to start the quests, for those experiencing bugs.

If those still fail for you, we'll have to wait until Bethesda fixes this issue with one of the official patches, or until the Unofficial Skyrim patch team fixes this issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .