So my League of Legends version is a little behind, and I'm getting it up-to-date. However, it will not let me download the next file in the update, stating

Unable to connect to the network, please try again later.

So, I waited a while, and tried again later, just like the magic 8-ball instructed. However, I am still not able to connect. In looking into the logs, it says:

03/05/2012 17:00 [WARNING] Attempt to retrieve metafile[LOL.Air/93/LOL.Air_93_90to93.solid]
03/05/2012 17:00 [INFO] [LOL.Air] State change [PATCHER_STATE_PREPARE] to [PATCHER_STATE_FAILED]

Which leads me to believe that it can connect, it is just having troubles with the files. Does anyone know of a fix for this updater issue?

Update: Apparently others have had the same issue, but there doesn't seem to have been any resolution.

  • Honestly? You might need to do a clean install. That should be a last resort, though. Commented Mar 6, 2012 at 1:17
  • @RavenDreamer :/ Not how I want to spend my "avoiding work" time... But yeah, that will be my last resort. If there is just a single file that I can delete though, that would be preferred. Commented Mar 6, 2012 at 1:18
  • To me that DOES look like a problem connecting, I would break it down as, a) it used some sort of "meta" file to connect to a server or peers, and failed (the logs may blame the meta file for this). It then attempted to download a new meta file from a central repository and failed that too. Just a guess though, but judging from the higher level message that is interpreting the logs, you might need to still wait, or figure out what is blocking the connection.
    – Resorath
    Commented Mar 6, 2012 at 1:22
  • @Resorath I'm not sure if it is. I found this post which shows the same error I'm having with the same version update file, and this was a few days ago... I'll keep investigating and maybe answer it myself. I'll also update the question to include the post link. Commented Mar 6, 2012 at 1:30

1 Answer 1


Apparently, in spite of other people with similar issues, the problem was just an issue server side. After some time I was able to download the update without trouble. As @Resorath suggested, the logs likely indicate trying to find it locally, then on the server, and then notification of failure.

If you continue to run into issues, reinstalling the game may help. This ended up to be the quicker thing for me to do, rather than waiting for the server to connect.

  • 1
    I will. I just have to wait 2 days before I can :) Commented Mar 6, 2012 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .