6

I have a superflat test world, where I was going to do experiments with mob farms. Except it seems that for some reason, everything is lit up, as if I were building it out of glass. (it gets dark once it turns night though). Everything is perfectly normal in my non-superflat worlds...

Daytime: Completely enclosed room. Should be totally dark, right? Apparently not.

Nighttime: Enclosed room at night - as you can see, there is a discrepancy.

Any ideas? Or is this probably a bug?

5
  • 4
    Screenshots are your friend :P
    – user9983
    Commented Mar 6, 2012 at 1:55
  • I'm not able to reproduce with a smooth stone cube in superflat creative mode.
    – Resorath
    Commented Mar 6, 2012 at 2:05
  • I saw this for a few minutes in SMP today. Commented Mar 6, 2012 at 2:10
  • I saw this when I was digging a tunnel between the grass and bedrock, in 1.2.3 (but the world was created in 1.2pre). However, it fixed itself when I removed and replaced the ceiling grass, so that's a different case.
    – Kevin Reid
    Commented Mar 6, 2012 at 13:11
  • I've tested this over and over again by making 1x2 rooms out of stone around me, and making sure that every block around me is in place... but with the same result.
    – Unionhawk
    Commented Mar 6, 2012 at 14:14

2 Answers 2

3

If you are running on preview 12w07, lighting was not calculated properly, this was fixed in a later version. If not it may be that it was generated in this preview and has the same issue. Try placing a light source to force a lighting update.

4
  • I'm running Minecraft 1.2.3. The world was created whenever they added superflat (1.1?), and converted to Anvil in 1.2, I think. (it was either 1.2 or 1.2.2, or whatever; not 1.2.3), and I have never used a weekly build.
    – Unionhawk
    Commented Mar 6, 2012 at 14:10
  • have you tried placing then removing a torch? even if this was not the cause it should force a lightning update. at any rate, it seems that lighting is calculated from daylight, which was a known bug in 12w07 (the first release of anvil).
    – legacy
    Commented Mar 6, 2012 at 16:38
  • 1
    For some reason, the ceiling isn't blocking out the light. Replacing it is working (the torch idea didn't though...)
    – Unionhawk
    Commented Mar 6, 2012 at 22:49
  • It looks like a bug... a weird one at that, though.
    – Unionhawk
    Commented Mar 7, 2012 at 0:41
0

I believe there is a lighting option when you click: esc

Brightness I think? Maybe yours is too high.

1
  • This does not change it; I'm running with highest brightness all the time. It can still get to light level 0.
    – Unionhawk
    Commented Mar 12, 2012 at 11:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .