When trying to install Mass Effect 3 on my Windows 7 machine I got the following message at 99% installed:

Mass Effect 3 DirectX Setup Error

I have made sure that i have the most resent version of DirectX form the web installer.

I found this video when searching for a solution

But I don't see a DirectX folder in the Mass Effect 3 folder.

  • This is also the case for Mass Effect 1
    – karhell
    Dec 26, 2016 at 12:59

5 Answers 5

  1. Go to C:\Program Files (x86)\Origin Games\Mass Effect 3\ __Installer\directx\redist

  2. Delete all the contents of the folder except for the following files: DSETUP.dll dsetup32.dll DXSETUP.exe

  3. Install Mass Effect 3 again.

Note change the Go to C:\Program Files (x86)\Origin Games prefix if you installed to a custom location.

  • This was my problem. The DirectX folder was already inside the __Installer folder
    – Blem
    Mar 12, 2012 at 18:09
  • 1
    This fix works for Command & Conquer Generals too. Thanks!
    – LolCat
    Apr 15, 2015 at 23:56

Have you tried running DxDiag? See if you can get any additional information from there.


DirectX Diagnostic Tool helps you troubleshoot issues with the DirectX suite of multimedia technologies that come with Windows. If you're having trouble getting game animation or a movie to run properly, you should run DirectX Diagnostic Tool to try to find the source of the problem.

To run DirectX Diagnostic Tool:

Open DirectX Diagnostic Tool by clicking the Start button, typing dxdiag in the Search box, and then pressing ENTER.

Note: I know this would be better as a comment, but I don't have comment everywhere yet. Just trying to help.


Reboot your computer after install, worked for me when it did not work until I rebooted.


I had this problem and solved it by granting admin permissions for all users on the origin folder, then installing DirectX 9, and only then installing the game.

  • Most people use non-administrator user profile, so granting Administrator permissions, seems overkill
    – Ramhound
    Apr 18, 2014 at 11:49

Had same problem, and used what tiddy said. Deleted the files except those three and then the game started updating. Its all good.

Some more problems and solutions for ME3 installation are also here (including the answer above) http://segmentnext.com/2012/02/26/mass-effect-3-errors-crashes-freezes-frame-rate-fix-origin-and-fixes/

credits to the ones who made them

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .