1

How well does Turbine's Lord of the Rings Online work in an emulated Windows XP installation using VMWare Fusion, Parallels or other emulation systems?

1
  • unplayable in my experience. anything with graphics is going to suck on a VM. Aug 16, 2010 at 20:17

4 Answers 4

2

In a VM it's completely unplayable. Think in terms of measuring framerate in seconds per frame, not the other way around.

HOWEVER... LotRO runs just fine on a Mac in Bootcamp. I played for well over a year on a 2.6 GHz MacBook Pro, running WinXP in Bootcamp. The downside is you have to reboot your machine into Windows instead of running it alongside OS X, but the upside is that any other Windows games will run just fine that way as well.

1

I run LOTRO with VMWare Fusion 3.0 on a Macbook Pro with a Windows 7 guest OS and I can run the game just fine. Definitely playable.

0

In general you're going to get mediocre performance when attempting to run GPU intensive games in a virtual machine. In most cases this will hurt the playability of the game and put you at a disadvantage when playing against others in a multiplayer environment. I would recommend against attempting any serious gaming in a VM.

That being said, a few VMs do support accelerated graphics. VMWare and VirtualBox come to mind. MS Virtual PC does not. I can't really comment on any other VMs. Since most VM software supports some form of rollback/undo disks, I would suggest trying it out on an undo disk. That way if it turns out to be unplayable its a simple matter to delete the undo disk and you haven't filled your VMs virtual disk with files.

Note: Using an undo disk has a slight performance impact as well. So once you've determined if the game is playable merge the undo disk back into the main virtual disk to get the best performance.

0

If, by emulation, one might include Wine (with or without a helper like Lutris, Play on Linux, or Play on MAC, then yes, the game is very playable on such a system, though accelerated graphics support is largely required. While 32-bit has been supported for a very long time, at the end of 2022, use of a 64-bit client will be required. Lutris has been used for both 32-bit and 64-bit clients (scripts to install are provided), and the LOTRO forums have a fair amount of information about getting it working.

Yet another Linux option might be Bottles as mentioned in a LOTRO Forum post related to issues with getting the game working under DX9.

Be aware that there are caveats. Some players have configuration and stability issues even when not running under emulation. At one point in time, my game became largely unplayable until I was able to figure out how to enable DX11 support ... which was not a trivial affair since at the time, the option of selecting DX11 was greyed out. Achieving a functional game with occurrences of this nature may put the game out of reach for some who find technical things daunting.

As for running under VMware, I was able, on a high-end laptop, to get the game to play. That said, it was very difficult to configure. I had all sorts of issues with mouse input, camera control, etc. It is easy to see how some would give up and consider it unplayable. I posted how I succeeded on the LOTRO forums:

vmware-Workstation-16-and-Win-10-Pro-x64-with-underlying-Intel-iRISxe-Graphics-(works-fine)

A summary follows: Both DX9 and DX11 were tried and didn't make much difference with respect to playability though I found better success with playing full-screen. At first, I had to set Options | Input | Mouse Look Sensitivity to 0.00. Even 0.01 was too twitchy! I also ramped up Options | Input | Mouse Look Sensitivity to 0.50 or higher. With these settings I was able to wander around and mostly play except that it was still too easy to get my camera view off. It was important to use the WASD keys more than the mouse. Setting Camera Aligns to Slopes [x] helped a lot. Other things were tried, but didn't seem to improve the situation. I could landscape relatively well, but there's no way the configuration was suited to heated battle.

After digging around a bit, I stumbled across How to disable mouse integration in VMware Workstation Player?. I edited the .vmx file and added a line (after another one that also started with "mks."):

mks.gamingMouse.policy = "gaming"

After that the game was perfectly playable. Again, a challenge for folk who find digging around for obscure workarounds, but definitely possible.

On MacOS, the situation is, as I read it, somewhat challenging, at least without procuring a commercially supported Wine environment. This is partly due to the "Mac" client containing a very old Wine, and will only get more difficult considering obsolescence of the 32-bit client. All that said, the LOTRO support forums definitely have knowledgeable people posting methods to make the game work, and at least some posters are remarkably patient at working through even very difficult cases.

Mac-Technical-Support

Though I have no experience with Play on MAC, I have successfully used Play on Linux

WineBottler: Run Windows-based Programs on a Mac might be yet another option for some.

I realize that by answering this 12 years later, the landscape has changed since some other answers were written, but the question is still legitimate, and merits some newer information for others that have the same question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .