0

I'm looking for a batch command which allows you to change name on an "online-mode=false" Minecraft server.

I have tried these commands and lots of others:

java -Xms512m -Xmx1024m -cp "%APPDATA%\.minecraft\bin\*" -Djava.library.path="%APPDATA%\.minecraft\bin\natives" net.minecraft.client.Minecraft '"'%1'"'

@SET /P IGN=IGN=
@java -Xms512m -Xmx512m -cp "%APPDATA%/.minecraft/bin/*" -Djava.library.path="%APPDATA%/.minecraft/bin/natives" net.minecraft.client.Minecraft %IGN%

I'm running Mincraft via this command for now:

javaw -Xmx2048m -Xms2048m -jar "C:\Users\Seras\AppData\Roaming\.minecraft\bin\minecraft.exe"

I have Windows 7 x64 with Java 7 (build 1.7.0_02-b13, should be a 64-bit version).

Edit: I'm running the latest minecraft unmodded. Btw found this "Client version 1.2.2 does not accept the command line arguments that previous versions accepted." so if anyone can get a command that works on a Client version 1.2.2 or later please post your command line here.

7
  • gaming.stackexchange.com/q/53095/8581 may help you.
    – James
    Mar 23, 2012 at 1:56
  • Btw when I run:
    – Seras
    Mar 23, 2012 at 8:59
  • java -Xms2g -Xmx2g -jar "C:\Users\Seras\AppData\Roaming\.minecraft\bin\minecraft.exe" -Djava.library.path="C:\Users\Seras\AppData\Roaming\.minecraft\bin\natives" net.minecraft.client.Minecraft "127.1"
    – Seras
    Mar 23, 2012 at 8:59
  • It tries to connect to a server on 127.1 (localhost)
    – Seras
    Mar 23, 2012 at 9:00
  • James; nah the thing is that I can't even run minecraft via that command... looking for a command that do the same thing and works on my system.
    – Seras
    Mar 24, 2012 at 1:29

1 Answer 1

6

I don't think you can change your username (unless hacking or spoofing is involved - and I won't cover those) on online-mode=true servers. The only way would be for the server you're connecting to to support commands (via mods) that are IRC-like which allow users to go by aliases.

1
  • Obs forgot to edit the true part :P it's an online-mode=false server. Fixed it in orginal post.
    – Seras
    Mar 24, 2012 at 1:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .