In Weeping Waterfall stage (screenshot of menu), right about here:

there is a secret on the ground near the trees, which looks like several concentric squares when viewed in first-person view:

I cannot for the life of me figure it out, can anyone shed some light on it please?

  • It's not gold because you ARE missing a secret that does count. Remember the owls?
    – user24015
    Apr 17, 2012 at 0:36

5 Answers 5


These are decorative Easter eggs, not a puzzle. Your map node is white most likely because you have another room to find. (Perhaps this one.)

The concentric squares have no bearing on the game or its completion. There are many of them scattered around with different numbers of rings: in Gomez's village (1), atop the broken arch stage (2), atop the bell stage (3), on the 4-cube door's floor (5), atop the waterfall stage (6), on the 16-cube door's temple-under-construction ledge (7), and on the same ledge in the temple warp zone (8), for example.

  • Hmm, well I've done all the secrets I can see on this stage; the two doors, lowering the water level, and there's still a Secret marker on the stage. Don't know what it is, but I assumed it was that as it's the only other thing I could see.
    – Xun
    Apr 16, 2012 at 6:28
  • This version is also very buggy. Are you in New Game+? If not, many rooms erroneously marked as incomplete "go gold" upon finishing the game. Also offhand, there are six doors in the waterfall stage: the TWO bombed doors (mine shaft & infinite stage), the TWO tetromino code doors (valve & pink/blue), the door that was once underwater ("What's my name"), and the tree trunk (pangram stage). If you've finished all of that, it's just the bug.
    – Wolf
    Apr 16, 2012 at 6:49
  • And where's the one with 4 squares ?...
    – Gimlao
    Apr 17, 2012 at 10:20
  • >! There is something you're missing that will gild this room's edges in gold you have to talk to the owl that appears at night. Dec 21, 2013 at 8:07

As far as I know this has no purpose. I've tried to stand on them while inputting the burned treasure map code to no avail. The stage is gold for me, since I found all the doors out, so I don't think it has a bearing on your completion.


I'm just putting it out there, the locations of these squares seem to (mostly) match up with the paintings in the room where you push open the book case.

There are also 7 paintings, and (IIRC) the other half of the burnt map code is only 7 buttons long. Maybe there's some connection.

This game, specifically the burnt map code, is driving me crazy. Especially since I do not want to cheat and just look it up online.

  • This does not answer the question, it just provides a theory. Also, fyi, nobody has solved the burnt map code without looking it up on the internet. Oct 12, 2012 at 23:42
  • Well... the very first person probably had to figure it out on their own... Jul 27, 2017 at 1:58
  • No, the game code was read to find the solution. May 18, 2022 at 1:25

To answer Gimlao's question:

The four-square concentric rings are in the forest level with the "totem" statue, where you temporarily lose your ability to rotate the world in 3D. Not sure if they're normally visible there in first-person view, but a pair of contributors at GameFAQs found the image file in that level when they decoded the game's resources.

My general theory (spoilerish):

the rings represent the same place in space, at different points in time. The largest set of rings is in the past in the 2D ruins, and the smallest single square is in the "present" (at the top of the Village.) It's where you meet the Hexahedron at the beginning, so maybe this links to the Tome haiku about the point of origin. It could also mean that the mobius "loop" in the candle room with its zero and one squares represents the beginning and end of time, or time folded back on itself?

That's interesting that the paintings link to the square locations!


I don't believe this pattern has any use,because if you use a code that is associated with the burnt map in The Black Monolith room,which is possibly the hardest room to complete,although I have done it,it is located I think near the Waterfall Area and you use First Person and you will the the large P that is also on the map.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .