9

Half-life (steam version) starts playing audio CD in my CD-ROM when game is loading and mostly stops it after game is loaded, but sometimes it plays forever.

Is there a setting to prevent it playing it at all?

4
  • 4
    Does it actually play the music or does the CD just spin up?
    – kotekzot
    Apr 16, 2012 at 12:34
  • 2
    And if it's the former, why not just remove the CD?
    – MBraedley
    Apr 16, 2012 at 14:06
  • It plays music. I know I could do that but I've been looking for a better solution :).
    – Samuel
    Apr 25, 2012 at 18:40
  • This is not bug, it's a feature. Greetings from Quake 1
    – Sanctus
    Dec 5, 2016 at 10:12

3 Answers 3

18

The original Half-Life had it's soundtrack audio on the game CD, and it seems the Steam version will still attempt to play audio tracks from any CD in the current drive if one is available.

This seems to confuse many people.

The fix is to remove any CDs with audio tracks from your drive while you play.

3
  • 6
    Wow, that's a pretty annoying bug
    – Ben Brocka
    Apr 16, 2012 at 14:25
  • @BenBrocka I like to think of it as a pretty awesome feature. Apr 16, 2012 at 18:23
  • 3
    Agreed, it is an awesome feature. It also worked for any HL mods, including Natural Selection (aliens vs. marines rts style mod). I remember one christmas I was burning some christmas music cd's, and left the last one in the drive. Fired up some NS, and jumped in on the alien side... "It's the moooost wonderful time of the CHOMP"
    – Kexlox
    Apr 16, 2012 at 20:54
0

I don't know exactly if this applies the same way because I have it on the retail version. The simple solution is remove any CD's while playing, but you could go into the options or configuration menu and click audio. Many options will appear, including one that says 'play CD music'. Uncheck it. I dont know if it'll be the same on steam, but that's how it works on retail. Hope I helped

0

You can't, but you can stop music (at the startup for example) with the command "cd stop" in your console.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .