Yesterday, I bought Titan Quest Gold via Steam and installed it with the German language files. After starting the Immortal Throne add-on, it imported my old characters from an old profile. After that, I faced the generally known "tag not found"-bug and fixed it with an update of the Text_DE.arc (211KB).

But there are still many missing tags which seem only to refer to the new features which were included with the add-on. The enchantment window, for example, is completely unusable. I've also tried to repatch the game to English but the add-on content texts were still missing.

I have searched for a solution, but I only found fixes for the general "tag not found" bug. How can I fix this bug?

2 Answers 2


I made the mistake of overwriting the Text_DE.arc in the IT folder with the one which was downloaded by the patch program. This file does not go to the resources folder of Immortal Throne. It must be placed in the resources folder of the normal Titan Quest installation, because TQ cascades its resources. After I placed it in the normal TQ resources folder it worked.


I was checking out Titan Quest related questions in here and noticed there are very few. So in case you still need help check out the TitanQuest.net forums. If there is a solution that's probably the #1 place where they will be able to answer it.

PS: There is also a fan-made bugfix patch which solves various known problem with the last official release (the one you get from Steam). It may or may not solve the language files issues, worth checking out.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .