Recently I have been having issues when trying to play a replay whether it is recent or an old one that I had saved. All replays show up as "Unable to Open Replay" here is a screenshot below: Starcraft II Replays not working. Unable open replay

So how do I fix this and re-enable myself to watch the replays?

EDIT- As a side note, this is the fully updated version. This is completely legit and I do not run third party software that would mess with the replays.

  • those are beta replays ? – Michel Apr 18 '12 at 0:25
  • Is this all replays? Play a game then try the replay of it. – Resorath Apr 18 '12 at 0:30
  • No these are all recent replays. All Replays and I have tried ones I just recently played. I used to be able to watch them fine, then suddenly I stopped being able to. – Nick122 Apr 18 '12 at 1:11
  • Assuming your client is legit and up to date...are you running any third party tools, like sc2gears, that may fiddle with replay file names/locations? – chobok Apr 18 '12 at 4:58
  • Nope, everything I have is 100% legit. No extra stuff no 3rd party tools. – Nick122 Apr 18 '12 at 8:29

I was intrigued by your problem and looked around for an answer. There was a bunch of references to this problem from 2010, but nothing new from this year. Then it was a bug that occured when you tried to watch a replay on a map that you had never played before. As you added the information that you also have trouble to watch replays of games which you just played the description doesn't match though. Adding the information that other people can watch your replays it is to conclude that your problem is specific to your computer.

Perhaps you can think back whether you have made any changes to your system just before the problem occured. Perhaps you installed some new software that messed with your starcraft2 setup in some unexpected way, or got a new anti-virus software or similar. Perhaps there was some change with your (windows?) user account lately?

If there are no such leads I would try chobok's suggestions from the question comments: Look whether your replays are still stored in the correct place with the correct permissions and lastly try re-installing the game if nothing else helps.

  • As far as I can tell, there were no recent changes to my computer at all. This is the only reason it bugs me. All of a sudden one day I went to review a game and I couldn't. No new software and no new anti-virus. I'm full administrator, etc. Replays I can find right in the replays folder. I can even hit the "show in folder" button on the SCII replay menu. However, it simply won't let me view them. I may have to re-install the game... only problem I have with that is the patching. I have to continuously restart the patch every few minutes. Took me forever the first few times to even play it. – Nick122 Apr 25 '12 at 10:51
  • But thanks for the answer. +1 and will try it and see if it is the answer :) – Nick122 Apr 25 '12 at 10:52
  • 1
    Have you tried to start the replay without having SC2 open first, i.e. just clicking the replay file before starting SC2? Perhaps that would offer up new information. Edit: Ah sorry, I had overlooked that you already re-installed. Hopefully it works! Good luck. – Murch Apr 25 '12 at 12:48
  • 1
    If all the earlier options fail, you have a choice of reinstalling, or contacting Blizzard's tech support. Please keep us appraised of your progress. – chobok Apr 26 '12 at 8:57
  • 1
    If it does come down to reinstalling "If I uninstall StarCraft 2 from my old computer, will I be able to install it on a new one?" could be useful – chobok Apr 26 '12 at 9:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.