I'm still at the start of the game but one thing is annoying as hell: whenever I'm maneuvering around in the map and the game needs to load something (e.g. a sound or such a thing), there's a stutter or a short pause so to say.

E.g. I climb up something it's clear that the game suddenly pauses for the sound load (at least that's my impression) the first thing it needs to play it. I've also saw this the first time the wolf came at me right in the tutorial: a short stop and then the sound played.

What's also really annoying about this is that it almost always breaks the tension because I already can expect something to happen the next moment.

I'm on a W7Pro 64 with 12GB RAM, i980EE@3.3Ghz with Intel 160GB SSD and a HD 5970 so I hardly think it's the spec not being enough and thus all my searching with Google and friends turning nothing up (they usually expect hardware not sufficient problems).

I also notice some weird stop, albeit less annoying, when calling up the Objective or Log screens (I expect the game to pause in this case, so no problem).

  • Tried to add tags like call-of-juarez and stutter but not possible with < 150 rep.
    – Turrican
    Aug 28 '10 at 15:05
  • Added call-of-juarez. Don't think stutter deserves it's own tag.
    – Macha
    Aug 28 '10 at 15:06

Changing affinity as suggested by CJM made things just worse as long as less then four CPUs where selected. But it didn't improve anything at all.

I didn't bother with the disk performance tools, wouldn't believe I'm in trouble with the SSD as I know (and have measured in the past) my throughput is around 200MB reading.

I've no such hogging background processes, I don't run antivirus (exactly because of this). Checked with msconfig.exe, all automatically started services looked normal and tools started on system startup looked good as well.

Finally I tried to play around with compatibility setting when I found a CoJ_DX10.exe in the game directory. It never occurred to me this file exists as typing Juarez in the W7 start menu only provides my on links which starts up CoJ.exe it seems.

After starting CoJ_DX10.exe and configuring my settings (everything maxed out at 1600x1200) and played again from the start -> there was no stutter at all anymore. Besides, it looks better still at 85 FPS ...

So simple I can't believe it.


There are two possibilities I can think of. The game performs poorly on 64 bit systems, or the game performs poorly on multi-core systems. Some games which were optimised for two cores works poorly on quad (or more) core systems. Fallout 3 for example crashes on some quad core systems unless you edit a configuration file.

  • Hmm, interesting. Never had any troubles so far, even with older games (way older then CoJ). F3 plays well on my system. Any concrete idea what I can do?
    – Turrican
    Aug 28 '10 at 15:35
  • @mark: Nope. Sorry.
    – Macha
    Aug 28 '10 at 15:44
  • You can test this by modifying the processor affinity and by using application compatibility settings: addictivetips.com/windows-tips/…
    – CJM
    Aug 28 '10 at 20:27

Beyond application compatibility and processor affinity, you also need to consider background processes. Anti-virus apps are the old favourites, but any background application could potential be a problem. I suggest using msconfig.exe to temporarily cut out all but essential processes before playing the game.

It might not yield results, but you need to cross it off your list.

This stutters are often due to disk bottlenecks. You'd hope this wouldn't be the case with an SSD but you never know - you need to benchmark your disk system (HDTune).

Post back with your observations and we might be able to dig deeper.

Q: Is it just CoJ that suffers in this way? I assume you are fully patched? If it is just CoJ, I'd log a call with the developers...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.