I gave Wujeeta the potion, talked to her, and there's still no option to intimidate her to the point to tell me who is her dealer. Has anyone else had this problem?

All it lets me ask is "What is skooma?" and after that there are no other options. Is there any other way to get the key from the Jarl? Because I have done a lot of things since I gave Wujeeta the potion and I do not really want to go back through all my saves and re-do everything I have already done.

  • 8
    I don't understand very much about Skyrim, but why this question got -1 ? The question could be better structured but -1 without edit/comment is kind harsh.
    – Michel
    Commented May 4, 2012 at 1:52
  • I deleted my answer. I've understood that you were asking for the way to complete the quest. I looked around and didn't find any information about this bug, the only bug related to Wujeeta is "(PC) Unable to complete "Skooma Trade": Wujeeta is killed by a dragon and the skooma trade quest can no longer be avalable to complete. resurecting her will just yeild the resualt of dialog as if you had competed the mission, thus preventing you from even obtaining your "Honeyside" (your house in riften) from the Jarl."
    – Michel
    Commented May 4, 2012 at 15:01
  • @warsong hi there, Don't worry about those -1, you can +1 and edit because of that. We try keep the post as good as possible, so if you see something that looks wrong, just Flag, Edit, Comment or +1 that. My questions and answers were HORRIBLE! (in all stackexchange) So I get in the chat and improve it. Now I can make good edits, answers and question. People here are VERY kind and helpful, but we saw a LOT of bad posts. Just try help us. =) (btw, take a look at our chat, so you can talk more about it)
    – Michel
    Commented Jul 9, 2012 at 14:15

4 Answers 4


If you cannot convince her you will need to see if you can gather the information through other means. Perhaps she has some incriminating evidence on her person that you can obtain through guile or by force.


Do you have the PC version of the game? If so, you might be able to reset the stage of the quest to a point from where you can continue. You need to open the console (usually with the tilde key (~)) and then type the following: setstage FreeformRiften12 stage Where 'stage' is a number that you can find on the uesp wiki for skyrim: http://www.uesp.net/wiki/Skyrim:Helping_Hand

I hope this helps you out!


I wanted to point something out. I was having the problem that the dialogue with Wujeeta to take the information to the Jarl wouldn't generate. I would give her the potion as requested and she would never refresh the dialogue options. Reloading, waiting, and trying different ways of getting her the potion per her dialogue options didn't work. I also wasn't getting notifications for the beginning of the "Identify Riften's skooma dealer" quest when I gave her the potion.

After digging in my Miscellaneous quests, I found it. It never gave me the overhead notification that the quest was added. Only once the quest was active did the dialogue option to take it to the Jarl appear.

I'm hoping this may help them in the future. Not sure if it is a total fix, however. It's just how I managed to get it to work (finally).


Possible Solution: Wait 1 hour after giving her the potion and talk to her again

Description: I had the exact same problem.

I would give her the potion but the option "where do you get your smooka" would not appear. I did not have any quest and no further option.

Waiting 1 hour after giving her the potion solved it. When I talked to her again the option "where do you get your smooka" was there and I could start the quest.

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .