Ok, so I wanted to download a mod. But the mod has nothing to do with the problem... Anyway, I went to delete the META-INF file in the Minecraft .jar (or Minecraft) and it did not delete, due to the file is being used by a program. I then tried to delete the Bin folder since that worked in the past with different problems. So I went to delete the BIN, and it said cannot delete, because Minecraft is being used in Java(tm)SE-BINARY. I opened Java and it closed instantly.

What can I do to get my mod on the game because the folder wont delete ANYTHING? Unless I can find out what program is currently using Minecraft?

  • 1
    Are you sure you are not running Minecraft? May 5, 2012 at 21:15
  • I wanst running it Ive been modding for a while and know not to have it open at the same time im doing work May 5, 2012 at 21:18
  • 7
    Try rebooting? That should make sure nothing's using those files. If it still gives you the error, then you have a bigger problem. May 5, 2012 at 23:25
  • 6
    Run task manager and check for javaw.exe if Minecraft doesn't show up in the task bar. You can definitely delete these files, but you definitely cannot if they are being used.
    – Chris
    May 7, 2012 at 17:42
  • Why down voted? I had the same question! (upvoted) Found this on google Nov 7, 2014 at 23:37

7 Answers 7


The easy way is to restart your computer and try again. If this doesn't work try to close all apps in Task Manager manually.


Type this command into command prompt, this should fix your problem. You can launch command prompt by doing Start Menu -> Run, then type in CMD.

taskkill /f /im javaw.exe 

Once you do this you should be able to delete the file.

What this does is tell Windows you want to close the Java application that is currently using Minecraft. Once this happens it will free up the file and allow you to delete the file.

The other options is open up your task manager and if you see any instance of javaw.exe to end task the program.


Exit ALL of Minecraft, and all Minecraft-related applications. If this doesn't work, delete each folder individually.


I recommend quitting all applications that could possibly be related to minecraft. That should work as I've had similar problem not specifically with minecraft, but once all applications related to it were quitted I could remove any of its files.


OK, this will work; I just did it:

  1. Go to minecraft but don't log in.
  2. Go to options and it should say "force update".
  3. Click that and then login.

It will refresh everything but you will have to redownload all of your mods.


Go to the task manager (Ctrl + Alt + Delete).
Go to Processes and find javaw.exe, then click End Process.
Then try to delete the file.

If that doesn't work try to restart your PC and try again.

  • It is javaw.exe, not Java.exe
    – Timtech
    Aug 2, 2013 at 23:45

There could be a program running inside of META-INF. Go into Task Manager and if you find the program there, end the process. After that, try deleting META-INF and it may work. You cannot delete a file if a program is running inside it, or if you are trying to run the program itself, it can't be running.

This site is temporarily in read-only mode and not accepting new answers.

Not the answer you're looking for? Browse other questions tagged .