While playing Mass Effect 3 multiplayer as an infiltrator, about 30% of the time that I use Tactical Cloak it turns itself off within a second, triggering the cooldown again. Is this a bug that other people have experienced? Is there a way to keep it from happening?

Edit: I should mention that I've run into the problem while using both Geth and Salarian Infiltrators. I use this build with a Geth Pulse Shotgun in case that helps. I realize that starting to charge the shotgun breaks cloak, but I am not doing this.

  • Are you shooting your gun and/or pressing the cloak key again? Commented May 6, 2012 at 1:12
  • No shooting or using of abilities of any kind, just moving around (which shouldn't be an issue).
    – Brysonic
    Commented May 6, 2012 at 1:35
  • 2
    have you tried it with a non-charging weapon, just in case? Commented May 6, 2012 at 3:08
  • 1
    Are you still having this issue? When I played an infiltrator, I had to teach myself to be careful with the cloak button - sometimes when waiting for a cooldown to finish, I'll impatiently start tapping the button of the ability I want to ensure I use it ASAP. Doing so with cloak led me to occasionally over-tapping it, and breaking my cloak near-immediately.
    – Izzy
    Commented May 12, 2012 at 23:06
  • 1
    @RavenDreamer It took me a while, but I tried several rounds using a non-charging shotgun and didn't encounter the problem at all, so I think that you're right. If you'd like to submit this as an answer I'll accept it.
    – Brysonic
    Commented Jul 24, 2012 at 11:21

2 Answers 2


It sounds like you're having a negative interaction between tactical cloak, your charging weapon, and possibly also your latency.

Since you've mentioned it doesn't have any issue with "regular" shotguns, I think that the bottom line is that Cloak hasn't been failing for you, though it probably has been behaving in a way contrary to what you were hoping.


The only scenarios in which my cloak has broken are the following:

  • Shooting a bullet, or performing a melee attack
  • Using a power (unless you unlocked the skill to perform one while still cloaked).
  • Being impatient and spamming my cloak hotkey.
  • Receiving damage from an already initiated attack, or splash damage from a grenade, etc... Receiving damage in general breaks the cloak (as it does with Geth Hunters).

Also, I've noticed that the enemies aren't completely baffled by a cloak. If they see you cloaking, they will assume you haven't switched location and will try to attack that location.

Can you confirm if you may have taken damage right after cloaking?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .