9

I want to play empire earth on my netbook, with win7 pro 32bit, but it crashes. When I start Empire Earth, the videos are played as usual and when the game starts, it crashes. I've tried different compatibility modes and Admin permissions, but nothing worked. Also I installed the latest patches and the Add On (Age of Konquest), but it didn't work. Any Ideas what I could do?

Update

After all that time and many tries, I assume that it is not possible to run ee-zde on my nb. I guess the problem is related to the intel graphics card. Anyway, I will accept the answer with the most votes to get this to an end.

  • Empire Earth is Old? It's fully 3d for crying out loud. (Commenting on original tags) – C. Ross Sep 2 '10 at 12:29
  • Depends on how you define "old". – Michael K Sep 2 '10 at 13:04
  • This is why I don't think we should have tags for old/classic games; too subjective, requires too much maintenance, and it's not particularly good as a filter – Mana Sep 2 '10 at 13:41
  • A solution that almost always does the trick for old games: Use a Virtual Machine. Install the required OS (in your case Windows 98 or XP) and the game. Everything should work just fine. – ayckoster Oct 10 '12 at 12:21
  • 1
    Have you tried buying it from GOG.com? Usually, they get it right. – Iszi Oct 10 '12 at 16:10
3

Could this be the same type of issue that affects other RTS games?

Try closing Explorer.exe either before running the game, or right after it starts.

Here is a question that is asking about older RTS games: How do I get an older Windows 95/98 game to run in Windows 7 64-bit without some colors looking off?

| improve this answer | |
  • I'm sorry for the late reply, but closing the explorer didn't solve my problem. – Michael K Sep 8 '10 at 17:13
2

Well I have the solution for this old problem, and actually it isn't quite satisfactory...

If you happen to have an old or new(doesn't matter as long as the resolution is equal to or higher than 1024*786) monitor you could just hook up this monitor to your Netbook with a RGB cable(the blue cable that is normally used to connect a monitor to a computer) then you must set your video output to the monitor only(that means that you will only be able to see your computer screen on the external monitor and that your netbook screen should turn black). Then you start up the game and... problem fixed, you'll be destroying other civilizations in no time^^. In case you don't have an extra monitor you could get one for under 40$, so that is quite cheap^^

Hope this helps(worked out for me:p) (found out I wasn't the first one to bring this up...)

| improve this answer | |
  • This may work, thank you for this idea, but I want to play empire earth on my netbook. Thus I don't want to use an extra monitor. – Michael K Jan 10 '11 at 11:08
1

The solution to your problem is simple... what you need to do is enable downscaling for your netbook's graphics driver in order to set your screen resolution to 1024x768.

To do this, first of all open "regedit" by going to Start and then Run and typing regedit. This will open the Windows Registry editor.

Next, click edit on the menu bar at the top and then click Search and search for Display1_DownScalingSupported:

enter image description here

Finally, double-click on the property we want and change the value from 0 to 1 and then click Ok. Restart your computer and then change your screen resolution to 1024x768 and you can play Earth Empire!

| improve this answer | |
1

I had a problem with both Empire Earth and Empire Earth Art of Conquest in Windows 7 Pro. Both games had no text and Art of Conquest artifacted (bad graphic glitches). I have a Geforce 780ti.

  1. Download a program Called DDU version 17.0.6.6. it uninstalls all the drivers for your GPU.
  2. Download the latest drivers from your GPU site (I think this might work for AMD also and put them on your desktop.
  3. Download the patch from NEO-EE to play on line.
  4. Uninstall and reinstall the games (or just EE) ( with any update patches from Sierra).
  5. Install the NEO-EE patch.
  6. Uninstall your GPU drivers with DDU.
  7. Reinstall your GPU drivers from your desktop.

Empire Earth and Empire Earth Art of Conquest will work perfectly. If you reinstall the games and uninstall and reinstall the drivers for you GPU and then the NEO-EE patch it will revert the games back to the problem you had in the first place, you must install the NEO-EE patch after reinstalling the game or games before uninstalling and reinstalling your GPU drivers.

You can try this method on 8, and 10 it might work. This method did not work for winxp home as far as Empire Earth Art of Conquest was concerned. Empire Earth worked fine in WinXP without this method.

| improve this answer | |
0

Try this

  • Restart/Shutdown after Extracting/Install
  • Run as admin
  • Change to primary driver (Setting)
  • Choose 2nd option 3D Hardware TNL (Settings)
  • Graphic quality choose the middle of Best quality and Best Graphics (Settings)
  • Change Autosave ,Frequency=20, To keep=1
  • 800x600x16 bit screen (Resolution)
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.