Yesterday I updated the Diablo 3 Launcher, now I got a "Failed to update tools" tooltip that when you dismiss it, it closes the launcher, how do I fix this fault scenario?

Here it would seem like many others have the same issue and couldn't fix it even after uninstalling...

2 Answers 2


Someone on the battle.net forums made this thread about the situation. A user named Nanon posted several potential fixes:

Fix #1

Go to Control Panel > Administrative Tools > Services

Scroll down and find “Secondary Logon”

Right Click > Properties

Change it from ‘Disabled’ to ‘Automatic’

Run your Diablo 3 setup as administrator and it should quickly go through Updating Setup Files and bring you to an install screen. Congratulations, your game now (hopefully) works! If this solved your issue, spread it around.

Fix #2

Right click on the Diablo 3 setup file you downloaded via the Blizzard Downloader

Select Properties > Compatibility > Check Run this in Compatibility Mode for… > Choose Windows XP (Service Pack 3) (Note: Does not work on Vista.)

Right Click the Icon, Run as Administrator.

Fix #3

Delete your C:\ProgramData\Battle.net folder.

Delete your C:\ProgramData\Blizzard Entertainment\Battle.net Cache folder.

Run the Downloader again, as administrator, and see if it gets past the “Updating Setup Files” window. If not, see Fix #1.

Fix #4

This one worked for me: try and find the agent application in the battle.net folder (for example C:\Documents and Settings\All Users\Application Data\battle.net\Agent). Start the agent application manually and after that start Diablo III setup file in your Diablo-III-8370-enGB-Installer folder. Good luck!

Fix #4

  1. Run the diablo insall thing… let it get stuck.
  2. Close it, and ctrl+alt+delete and end the “Agent” process.
  3. Go to C/programdata/battle.net/agent and run the “Agent” executable
  4. Run the diablo install thing
  5. WAIT! it will get stuck for a min or so and then work

Remember, I did not actually discover or try any of these fixes. They are suggestions, please let me us which one (if any) fixes your issue.


I was able to get past this by just running as Administrator. The tools updated succesfully, then I quit and relaunched so that the game itself wan't running elevated.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .