I have been looking across the internet for an answer to this problem but, alas, there is none. So I've come here.

I am currently trying to make a new Minecraft server on my laptop. My router is hooked wirelessly to my computer upstairs. I have followed the directions that have been said by many websites.

  1. I downloaded the Minecraft_Server .exe file from the website.
  2. I opened it and created a new world. I also typed in localhost and played around for a while.
  3. I went to my MediaLink properties. I went into the port fowards and entered in 25565 for the begin AND end port. I typed in my IPv4 address, chose TCP and UDP, and enabled them. I hit apply.

Now for my problem. I went to my brother's computer and tried typing down the IPv4 address and it gave me the connection refused error. I tried typing in the default gateway, the external IP address, nothing. I was getting pretty upset.

So my question is, what am I doing wrong? I really want to fix this solution. I have included some pictures to help.

Thanks in advance!

My port forwarding on MediaLink properties.

MediaLink properties

My ipconfig information in the command prompt

ipconfig information

The PFPortChecker tool


  • Incidentally, you only need TCP forwarded. It's possible that UDP has some positive effect, but TCP is sufficient.
    – user19220
    Mar 8, 2015 at 0:41

2 Answers 2


Two things:

  • first you have two conflicting rules in your port forwarding rules, you are telling to forward port 25565 either to either to your machine, you need just the latter one
  • if your brother computer is inside the same network of your laptop then you don't need to open any port on the router (unless you want to allow people from outside to connect to the server) and you have to specify your local IP address ( when trying to connect.

Of course any client from outside your network should try to connect to your external IP (the one shown in the port checker page).


What IP address are you typing in on your brother's computer? If he is in the same network as you, then you need to make sure you are typing your local ip address, not your external ip address. As long as he is on the same network as you, he should be able to join using, without having to use port forwarding.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .