I currently own Civilization V, (not the Gods & Kings expansion,) and have the latest version of it and have subscribed to several items on the Steam Workshop, but when I start-up the game, none of them appear to be in effect.

I have enabled mods and can clearly see the MODS button on the main menu (as outlined by this:)

How can I enable Civ 5 mods on Mac OS X?

...but it still refuses to acknowledge any of the mods I subscribe to from the Steam Workshop. How can I enable these mods specifically?

  • Have you checked to see if the items you subscribed to are updated to the latest version, and to make sure they don't require G+K expansion?
    – Lawton
    Commented Jun 29, 2012 at 19:13
  • Yes, most of the items that I downloaded were from even before the G+K expansion release. I think it has something to do with my Mac, but there's almost nothing about it on the internet.
    – user21079
    Commented Jun 29, 2012 at 22:37
  • Same problem here, it says subscribe as opposed to install and nothing happens when you subscribe Commented Jun 30, 2012 at 1:26
  • @LessPop_MoreFizz - I'm not interesting in self-modding since I know nothing of it, I'm merely interested in the Steam Workshop function that no one on Steam or Aspyr seems to notice isn't explained at all for Mac users.
    – user21079
    Commented Jul 3, 2012 at 2:00
  • 1
    After you subscribe to mods, you have to open the mods menu and enable them for them to take effect. You don't see the mods menu because you're playing on a mac - in practice, this absolutely is a duplicate of my old question, so I'm going to close it as a duplicate. If you've tried the solution there and it hasn't solved the problem for you then please edit this question to explain why the other question is unhelpful, then flag this question for re-opening.
    – Oak
    Commented Jul 3, 2012 at 4:43

7 Answers 7


As per this article on Wikipedia, downloadable modifications from Steam for Civilization 5 aren't supported on Mac's.


From the civfanatics forums for Gods and Kings on Civ 5 Mac from Aspyr installed with steam

Edit this file (which may be hidden):

~/Library/Application Support/Steam/SteamApps/common/sid meier's civilization v/Civilization V.app/Contents/Home/assets/DLC/Expansion/UI/FrontEnd/MainMenu.lua

This file may have moved (depending on your version) to:

~/Library/Application Support/Steam/SteamApps/common/Sid Meier's Civilization V/Civilization V.app/Contents/Assets/Assets/UI/FrontEnd/MainMenu.lua

Add "--" to the start of line 38 so it reads:

-- Controls.ModsButton:SetHide( true ); -- MAC_PORT - rickb Comment this line out to re-enable mods. Happy modding!

After that you must unzip any downloaded mods (including .civmod files) and place the resulting contents into the folder:

~/Documents/Aspyr/Sid Meier's Civilization 5/MODS

  • This works great! Though you have to place maps that you find in the .covmod file in ~/Documents/Aspyr/Sid Meier's Civilization 5/Maps as they're not picked up otherwise.
    – Pez Cuckow
    Commented Mar 22, 2014 at 12:12

I run on Windows and not Mac, so please, bare with me. If you have any experience with a Windows system, then this might be able to help you. If not, I apologize.

If Mac has a "My Documents" equivalent and/or a "My Games" equivalent anywhere, try going there and locating a file folder for Sid Meier's Civilization V (with or possibly without the Sid Meier's part). In there, you should be able to locate a file folder fairly quick-like entitled Mods. Go in there and see if there's anything in there. If there isn't, then your mods are likely not downloading correctly. If there is, then try the following.

If it's possible with the Mac Steam equivalent of Windows, try opening your Steam Game Library, right-click on Civ 5, and then go to properties (or whatever Mac has), then hit the Local Files tab, and finally click the "Verify Integrity of Game Cache" button. Allow it to run it's course and then start up the game. One thing: If you had files in your Mods folder from above and that doesn't work, try deleting them and repeating the process. Afterwards, redownload your mods via the in-game Mod menu. Make sure you are subscribed to your Mods. If this doesn't work, then I'm sorry, but I'm clueless and don't know why it's being dumb. =(

HOWEVER, if this issue is actually for a Mod you've downloaded for the Civ 5 Live Tuner or other programs for the SDK, say so.

Edited because I forgot some details.

  • The only issue I really want resolved is to be able to subscribe to mods via the SDK and have them appear in my MODS folder for Civ 5. The problem is when I do subscribe, it doesn't put them in that folder, and I can't find where'd they'd be, so I can't put them in that folder.
    – user21079
    Commented Jul 7, 2012 at 21:12

Adding mods via Steam doesn't work, and I believe there's no way to make it work. Instead you'll need to search the net for a direct download of the mod, and then install it as per How can I enable Civ 5 mods on Mac OS X?

NB: only some mods will work on a Mac.


I too was looking for how to easily use Steam Workshop mods with the Mac version of Civ V. I found that the mods do download as 7zip archives in your steam user data folder. I went ahead and built a program to automatically scrape the mods out and extract them to the MODS folder. You still have to edit your main menu.lua, but after that just use my app to do a scrape then launch the game.

the program and source is available here


I know this is really late but I had the same problem as you. I kept subscribing to mods but i couldn't find where they were going on my computer. I fixed the .lua file and found where the mod file was supposed to go in order for Civ5 to run it but i still couldn't find the file itself. I did a little searching and found this video. It is really helpful and tells you how to do everything.

  • 2
    Could you summarise the content of the video into the body of your post (using the edit link) in case it isn't available in the future?
    – Rory
    Commented Dec 18, 2013 at 0:00

Do try and browse the mods with the in-game mod browser, that was replaced by the Steam Workshop browser, and try enabling them there.

Edit: From what I read here It seems the most recent update makes mods malfunction on the MAC version of the game, read that post over there if you want more info.

  • Doesn't exist for the Mac versions. There is no "MOD" section in-game.
    – user21079
    Commented Jul 3, 2012 at 1:57
  • @NickAugello What about now then?
    – badp
    Commented Jul 3, 2012 at 11:55
  • Still doesn't work. I can "subscribe" to mods, and it definitely now shows a "MODS" section, but then it tells me I've added no mods. When I click on GET MODS, it takes me to the Steam Workshop page. I subscribe to mods, quit out of both Steam and Civ5, reboot, and the same "no mods added" message appears.
    – user21079
    Commented Jul 3, 2012 at 13:01
  • 1
    From what i read here: forums.civfanatics.com/showthread.php?t=399791 It seems the most recent update makes mods malfunction on the MAC version of the game, read that post over there if you want more info.
    – Skyxer
    Commented Jul 3, 2012 at 14:13

You must log in to answer this question.