1

For some strange reason, nobody on my Bukkit server can break or place blocks or use blocks (crafting table, furnace) without me turning them into an operator. I believe this to the the biggest glitch that minecraft could have. It is very annoying to the players and after speaking to a few people, I have come to the conclusion that it is most likely a permissions error. I use PermissionsBukkit as well as Vault and WorldGuard. Some help would be appreciated.

  • You didn't mention if they tried to break blocks away from the spawn. Can they? – smoth190 Jul 2 '12 at 3:37
  • 3
    They cannot break any blocks, even in the nether. – user28379 Jul 2 '12 at 15:08
  • If this is the case, then the problem is a plugin. As far as I know there is no vanilla option to disable building for all non-ops. – smoth190 Jul 2 '12 at 18:47
6

How far are they from spawn? It's likely spawn protection. To disable it, use spawn-protection-size=0 to your server.properties file.

| improve this answer | |
  • They are on spawn, and spawn-protection in Bukkit.yml is already set to 0 (there isn't one in server.properties). It gets annoying when I'm hosting a skyblock server. – user28379 Jul 2 '12 at 1:48
  • @JeffreyLin Try disabling all the plugins and see if the problem persists, then re-enable them one at a time to figure out what the culprit is. Figuring out which plugin is causing the problem is a good start to figure out how to fix it – Dave McClelland Jul 2 '12 at 2:13
3

If you're using PermissionsBukkit, users cannot build unless the node permissions.build is set to true. Check out the PermissionsBukkit configuration page for more info.

So, for example, to allow everyone to build by default (in your plugins/PermissionsBukkit/permissions.yml:

groups:
    default:
        permissions:
            permissions.build: true

If you only want one user to be able to build:

users:
    kuyan:
        permissions:
            permissions.example: true

You can also set a message that will be shown to the user if they attempt to build but don't have the correct permissions:

messages:
    build: '&cYou do not have permission to build here.'
| improve this answer | |
1

For this solution you have to use the plugin GroupManager.

Kind of found this by accident, but I use GroupManager and the way to solve it was to go into

plugins->groupmanager->worlds->world->groups.

Open with notepad++ or similar, then find default group and it should say: "build: false" Change this line to "build: true".

| improve this answer | |
  • 1
    Why would OP use GroupManager? He already said that he was using PermissionsBukkit (the PermissionsBukkit equivalent is permissions.build). – Nathan Dec 2 '12 at 22:33