I'm experiencing a strange problem in D3. I can't press escape to bring up the menu. It's only been happening for the last week.

Try rebinding the key.

Yeah, I've tried to do that but the rebind key is a different colour and it looks like it's disabled.

Maybe your keyboard/esc key is broken?

No, I've tried the escape key outside of D3 and it works fine. I've also got several keys assigned to my G keys (thanks G13 gameboard) and they don't work either.

Has anyone else had this problem? Is it a patch error?


I've found that if I press Shift+Esc it brings ups the menu. I don't think it's possible that the shift key is stuck on because I wouldn't be able to move if the shift key was stuck down

  • Not me. It's a bit hard to tell without knowing what are installed on your computer. I suspect it's a problem specific to you. Jul 7, 2012 at 3:38
  • I had this once... when you hit escape it minimizes instead of menu. If that is the case, that is a toggled on option caused (and fixed) by hitting ALT + ESC (hope that helps... there's a chance) Jul 7, 2012 at 4:03
  • I've also tried resetting the keybindings to default... that didn't work either :( I don't think I have any keys toggled...
    – Coomie
    Jul 7, 2012 at 5:30
  • I hope you've posted this in the official forum as well just to enhance your chance of getting some help. Have tried to change from fullscreen to windowed mode and then back? Does it work in windowed mode? Jul 7, 2012 at 8:28
  • Maybe you have another key that is stuck? IE. Alt, Ctril or Shift? It might do something like that.
    – Holger
    Jul 7, 2012 at 8:29

3 Answers 3


My brother had that problem with minecraft turns out the problem was a program runining in the background was disabling the escape key.

  • Could be a setting in your Logitech SetPoint where it's disabling it? Does the Windows key work also?
    – Neon1024
    Jul 10, 2012 at 14:45
  • 1
    Hey Alarick, welcome to arqade. I'm going to give this one to you because you're the most right answer. I restarted the computer and that seems to have fixed it...
    – Coomie
    Jul 11, 2012 at 0:51
  • @Coomie if restarting it honestly fixed the problem. It might have been sticky keys on Windows XP (assuming you are using that). It would make sense if holding shift would fix it under the scenario. IDK how many times I had to end a game of SC2 or other games cause of Sticky Keys. You can use this to kill it howtogeek.com/?post_type=post&p=1498 and hopefully that fixes it for good!
    – Falcon165o
    Jul 11, 2012 at 17:21
  • @Falcon165o I'm on windows 7 and I don't think it was sticky keys because wouldn't that mean shift was toggled on? In D3 I wouldn't have been able to move.
    – Coomie
    Jul 12, 2012 at 0:54

If you have Photoshop up and running while playing Diablo 3, the ESC key doesn't work. Closing Photoshop while running Diablo 3 will solve this.


Also verify that Stick Keys is not enabled. I know that is a pesky problem that can occur from time to time to ruin gaming on Windows Computers.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .