I'm working on the quest A Reasonable Man on The Savage Coast. I've just reached Tier 3, and I've been directed to 'Use a Telescope'.

Easy enough, I've found the scope, and if I pan around, I can see a big Zombie dude down on the beach. Seems simple enough, but the quest doesn't update.

I've asked around in General Chat, and the answer I've gotten is 'click a whole bunch near the filth spout.' Now, I've spent the last month playing a whole lot of . My clicking skills are the stuff of legend, and I have clicked the hell out of every pixel near that filth spout.

What am I missing here? Is this one of the many quests where quest objects become non-interactive and I can resolve it via shard-hopping? Or am I just completely missing the point?


Apparently this is bugged, but not to the extent that some other quests are. I'd try instance-hopping.

You're supposed to be clicking on/around the barrels/spout.

| improve this answer | |
  • 2
    I'd add that I just ran this again last night and it triggered the moment I clicked anywhere near the correct area while zoomed in. – Shinrai Jul 10 '12 at 14:19
  • Clicking did the trick for me as well. – Ingmar Jul 14 '12 at 21:12
  • 1
    Had exactly the same problem, just spam clicked around the barrels thanks to this post :) – kalina Jul 14 '12 at 21:58
  • for me this worked basically instantly when i zoomed all the way in – matejcik Feb 3 '17 at 22:02

Are you multi-monitor resolution? It's bugged at the very high res'es. If so, drop down to a single monitor resolution and complete it on one screen.

| improve this answer | |
  • I'm not, (1440x800) and spamming the barrels eventually worked for me but +1 for useful info. – LessPop_MoreFizz Jul 15 '12 at 13:48
  • Yeah, there are problems with some of the UI elements at those resolutions being misaligned to mouse clicks, so this actually doesn't surprise me. Good info. – Shinrai Jul 15 '12 at 16:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.