In %APPDATA%/.minecraft I have only a bin/ folder where there is a file named version and in the .minecraft folder I have a folder named resources and a text file named options.

Can someone tell me how I can get all files to play Minecraft? It says:

                        Failed to launch
            Fatal error occurred (4): connection reset

That is the text displayed when I go to minecraft.net in a browser but when I open downloaded Minecraft I cant log in and I cannot play offline because it says: Not downloaded.

Additionally, the Minecraft launcher does not load the HTML version history page. Instead, it just displays a blank grey background with black raw HTML.

  • 5
    Assuming english is your first language you really need to comeback and proofread this question. I'm so lost as to what you are asking I can't even edit it FOR YOU to help because I'm not always sure what you were trying to say. Assuming english is NOT your first language; Game Over, Continue? – Ender Jul 15 '12 at 18:14
  • What it looks like to me is that the server got disconnected or something during the download. Click options (in the launcher) and click force update. Then click login. Until you proofread as Ender said, we can't really answer. – Lysol Jul 15 '12 at 18:44
  • Also, welcome to Arqade. Please read the FAQ (or a dictionary) here: gaming.stackexchange.com/faq – Lysol Jul 15 '12 at 18:49
  • I've tried to clean this question up, see suggested edit – Joe the Person Jul 15 '12 at 19:06

Sounds to me that you have somehow gotten a partial download of Minecraft. The simplest way to fix this is to launch the client and choose Options -> Force Update. When you log in, Minecraft should automatically redownload the game files.

If that doesn't work, you may need to try a more brute force method. I would recommend just deleting your entire .minecraft/bin folder, then attempting to log in. If that, too, fails, back up your saves, and delete your entire .minecraft folder before logging in. Restore your data, and you should be able to play.


You need to allow Java to communicate through your firewall. On Windows 7, do the following;

  • Go to Control Panel
  • Go to System and Security
  • Click Windows Firewall
  • In Allowed Programs check Java to allow both private and public connections

The answer is to update your Java. Mine worked fine after I did this.

  • 1
    You should be a bit more detailed in your answer. For instance, did you have the same problem as nakkivm, why does updating Java fix the problem, and what problem were you having in the first place that you managed to solve? – Dante Nov 7 '12 at 19:39

protected by Community Dec 28 '12 at 21:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.