4

I have successfully setup a dedicated L4D2 server on my Linux box. I can manually connect to it with connect <myip>, so I believe I have all the basics setup correctly.

I'm trying to get the server to show up on the "Steam Group Servers" list so that its relatively easy to find and configure through the UI. However, its not showing up there. There are some servers in there from other Steam Groups I'm in, but not this server. (As far as I can tell, the server isn't showing up anywhere in the UI...) (A Steam Group seems like a nice way to make the server "private" without requiring a password.)

Here's my primitive server.cfg. Its got the right "sv_steamgroup" (I've double-checked, but have zeroed it out here.)


hostname "My Home L4D2 Server"
rcon_password "nothisisnotmypassword"

sv_contact "invalidemail@example.com"

sv_cheats 0
sv_clearhinthistory 0 //Clear Server Side Hint History
sv_consistency 1 //Enforce file consistency
sv_pausable 0 //Server not pausable
sv_allow_lobby_connect_only 1 
sv_voiceenable 1
sv_alltalk 0
sv_region 1

sv_steamgroup 000000 // Has valid number in real config file ...
sv_steamgroup_exclusive 1
// sv_steamgroup 0
// sv_password "thisisnotmypassword"
// sv_search_key "myuniquesearchkeyhasbeenreplaced"

sv_lan 0

sv_logsdir "logs"

//sv_pure 2

I've tried starting the server with and without steamuser/steampass. And, I've tried waiting a couple hours for the server to show up in the list. Any suggestions?

  • Assuming the server is behind a firewall, have you forwarded the necessary ports (27015 UDP for L4D2)? – DrFish Jul 18 '12 at 11:30
  • @Bora what difference would it make if it's already connectable via IP? – kotekzot Jul 18 '12 at 13:51
  • What about sv_region 1? Are all servers in the same region? – DrFish Jul 18 '12 at 14:34
  • @Bora I'm assuming its just port 27015 I need in the firewall. That works as verified by connect and pingserver from my desktop L4D2 console. However, since my desktop is behind the same firewall as the server, it could be fw problem ... I can telnet <ip> 27015 from a remote host, and the connection is established only if the server is running ... I'll see if I can find a better way to verify this works, though. – P.T. Jul 18 '12 at 17:12
  • @Bora My server and desktop are in sv_region 1 (US West Coast). I believe most of the other servers I'm seeing in the "Steam Group Servers" are in Europe/Russia (Lots of ".ru" servers?)? Maybe my client has some funky region setting? I'll investigate ... – P.T. Jul 18 '12 at 17:13
3

Here are the steps I did to make my L4D2 Source Dedicated server (srcds.exe) show up in Steam Group on my FIOS home internet (discover LAN games is turned off in client, so not a false positive):

  1. On my server firewall I opened all UDP and TCP port access for the program "srcds.exe" for public private and domain, both inbound and outbound.

  2. On my router I forwarded "any" inbound port to 27015 and 26901 on my server.

  3. Tweaked my srcds.exe command line so that the server would show "secure" while checking status in game (CLI inside L4D2 type "status"). Also, I switched from world server (255) to Western US (1) in my server config. I don't know if either of these helped exactly (probably not), but thought I'd share in case it did.

The key here is I did not know that you can receive on any port on your WAN IP, but that can go to any OTHER port on your LAN IP. I always thought it was one to one and only ever attempted port forwarding the ports one to one. As soon as I opened the inbound on my WAN source ports to "any", BAM!, my server showed up in Steam Group Servers. I wouldn't have ever known the fact that ports aren't one to one unless I used a tool called "livetcpudpwatch" to monitor ports opening while running my server in DMZ (for testing).

Here is my tweaked command line. I had tried with and without +ip and +port, but without seemed to work "best" for me, ymmv:

`srcds.exe -console -game left4dead2 +exec server.cfg +map c1m1_hotel -secure`

I am not a router specialist, so don't complain if your network gets hacked with these settings. My server is dedicated, and has no access to my network outside of serving L4D2, even so I feel these settings are low security risk, because the server and router can only pass traffic on 2 ports, and the only program listening on those ports is srcds.exe. If someone more router savvy wants to confirm my thinking, feel free.

| improve this answer | |
-3

try using the group's unique ID number this may be what its looking for, and you can find it at the top of the Edit Group Profile page.

if thats not it, try deleting the "//" because that means comment

| improve this answer | |
  • 2
    As a general note, I'm noticing you're posting a lot of answers. We prefer answers that show a higher level of quality than a regular forum. Try adding sources to your answers to back up your answer, and spend more effort to ensure your answers actually answer the question. This one, specifically, is a straight guess, so it doesn't actually answer the question. – Frank Mar 28 '15 at 0:02
  • 4
    Nope, no hate. We just have a higher standard here than most of the internet. Just trying to nudge you in the right direction to being a valuable member of the community. – Frank Mar 28 '15 at 0:11
  • 1
    @NightHawk You say "sound like my English teacher" as if it's a bad thing. – Yuuki Mar 28 '15 at 0:11
  • 1
    Who said this question is clear? I didn't. I'm just pointing out that your answer is a sheer, straight up guess. That doesn't qualify as an answer for us here at Arqade. The point of an answer is to solve the problem. This doesn't do that. – Frank Mar 28 '15 at 0:18
  • 1
    @NightHawk If it starts with "try", it's a guess. – You're bad and should feel bad Mar 28 '15 at 1:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.