6

In BF3 on PC I remember using bipods early on, but since about december/januari they simply don't work at all anymore. The animation is not there and neither is the effect (I'm spraying all over the place with the machine guns).

I tried switching on and off the bipods on all kinds of guns. None work.

I tried picking up a kit from someone I saw using a bipod... nothing.

I know I need a flat surface, but even when I'm flat on the ground.

Is there a setting that could cause this? A bug? Do I need to reinstall BF3 completely?

11
  • What system are you playing on? I'm guessing by the reinstall suggestion that you are on PC. So far i've only found people complaining about it. Maybe a patch issue
    – Samjus
    Jul 18, 2012 at 17:13
  • 1
    It seems to me harder to set it up now, you now have to hold the gun parallel to the flat surface for a second or so before it gets set up.
    – Ric
    Jul 19, 2012 at 7:51
  • @Samjus yes PC (edited question). It's not like I'm a big fan of bipods (have been playing without for half a year now...) but I did kind of like it to be honest. Just have to know what you're doing.
    – Jannes
    Jul 19, 2012 at 9:14
  • @Ric I'll give it another try, but I'm fairly sure I extensively tried that too.
    – Jannes
    Jul 19, 2012 at 9:14
  • As far as I remember, you cannot switch to bipod actively: It turns itself on when you lay your gun near a flat surface, and off again, when you move away. You don't even need to be in prone position.
    – DrFish
    Jul 19, 2012 at 9:16

1 Answer 1

6

One of the patches released earlier this year added the option to bind Deploy Bipod to a separate key than zoom. I'd venture a guess that this command is either unbound or bound to a key that you're not aware of. Try changing the key for Deploy Bipod in the Key Bindings Menu and see if that fixes the problem.

Bipod key bindings

4
  • Isn't that one for the sniper attachment?
    – DrFish
    Jul 20, 2012 at 18:26
  • @Bora I'm pretty sure it works for every weapon that has a bipod, which includes most automatic weapons as well as sniper rifles.
    – Brysonic
    Jul 20, 2012 at 19:08
  • Yep this was it: simple key binding... works perfectly now. I totally missed that change when the update happened. Thanks!
    – Jannes
    Jul 23, 2012 at 12:11
  • @Jannes You're very welcome :-)
    – Brysonic
    Jul 23, 2012 at 12:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .