I just bought a new PC with Windows 7 Home Premium 64-bit. Everything is peachy except Bioshock: it has no sound after the game starts.

I've searched on Google but can't find a definitive answer; or else the definitive answer doesn't work.

I tried changing the configuration file to use a different sound output system.

I tried using compatibility mode.

Nothing seems to work. The game worked well for me on Vista.

Any suggestions?

  • I had the same problems. After spending several days of fruitless efforts, I finally simply reinstalled Bioshock (I have it via steam) and the sound finally worked. – Raven Dreamer Sep 22 '10 at 13:40
  • oh @badp; re-reading that -- done, I don't think it's a resolved issue, re-tag again if you like. Leave bioshock and sound though, I think they're useful. – juan Sep 22 '10 at 14:05
  • What is your sound chip/card? – DrFish Oct 20 '10 at 8:35
  • @Bora: It's a Realtek High Definition Audio ALC889 built into the Asus P6X58D-E motherboard. – Mr. Shiny and New 安宇 Oct 20 '10 at 21:56

Try enabling the so-called "Stereo mixing":

(from http://forums.2kgames.com/forums/showpost.php?s=2ab258ea92a1bfbe6c783657b3633730&p=255517&postcount=1)

To do this, browse to Start > Control Panel > Sound (in classic view). Once done switch to the Recording tab which will show the currently active inputs on your system (e.g. Line in, Microphone). Right click in the clear space below these devices and select the option for Show disabled devices.

This should show an additional device called Stereo Mixing, right click on this device and select Enable.

| improve this answer | |
  • I tried that, no luck. – Mr. Shiny and New 安宇 Oct 20 '10 at 21:54
  • Okay, let's try to narrow it down: Try running the game with the -dx9 command-line parameter and see if you get sound. – DrFish Oct 20 '10 at 22:07
  • I recently re-installed the game on the same PC because I had to re-install Windows. THIS time I went straight to this approach before trying anything else. I installed the manufacturer's driver for the sound card (not the MS driver) and "stereo mixing" became available. I turned it on, and the problems were solved. – Mr. Shiny and New 安宇 Jul 6 '11 at 15:58
  • This worked for me - also had to set Compatibility Mode to Windows Vista (Service Pack 2) to get the video working right. – Steve Townsend May 24 '12 at 10:41

I have been correctly been able to run Bioshock on windows 7 platform. I too had the same problem when I had installed it. No sound. Well I tried the following steps in that order and it worked for me:

Step 1. Just run the Direct X installer that came along with the DVD. I know, we all probably have a later version already installed but for some games this step actually does work. Don't ask me why. I don't know.

Step 2. Update to patch 1.1.

Step 3. Use a no-dvd crack. Since I have a laptop I usually prefer not to use the dvd drive to much unless there is no other option. Well the game ran with this so I didn't make any further changes.

Let me know if it works out for you.

| improve this answer | |
  • I'm not the downvoter. But I tried that too and it didn't work. And installing a down-level version of DirectX seems a bit dodgey to me. – Mr. Shiny and New 安宇 Oct 20 '10 at 21:56
  • -1 for suggesting a no-dvd crack, where nowadays almost all of them contain malware. – DrFish Oct 20 '10 at 23:14
  • 2
    There are lots of websites that contain malware. Just saying that you could even get malware in a lot of ways. Doesn't mean that you stop surfing completely, right? Instead of downvoting the answer itself I feel a more appropriate response might have been to voice your concern. I could have provided you with the link where I got a malware-free version. – Mugen Oct 21 '10 at 19:16
  • 1
    Regarding step 1: this can sometimes fix issues because there were (and maybe still are) many different builds of DirectX 9 released; so having one particular build installed you may be missing components from another build that X game requires. Also, DX10/10.1/11 do not automatically include all components of DX9[x] – Xantec Nov 20 '10 at 16:04

I got it working by plugging in an extension cable into the front mic port on my case. My soundcard detected that the mic was present. After that the sound works. I have no friggin' idea why this might affect anything. I would still like someone to post a better solution though.

| improve this answer | |

Plugging in a microphone into the front port has worked for me as well. Windows 7 64 bit system. Had no sound before plugging in the microphone, but now it works with microphone plugged in. Try it!

| improve this answer | |

I had my HDMI plugged into my TV, and I guess the two audio outputs started competing. You need to right click audio manager, and then go click on audio devices. Once there you should make sure only one is enabled. This fixed my issue.

| improve this answer | |

Adding an alternative that worked for me as the other answers don't quite work that good (for me):

What worked for me was: in BioShock.exe's Properties > Compatibility tab, is to set it to 'Windows XP' compatibility mode. I also set it to run as an administrator but I'm not sure if it helps (I've had it enabled from the start):

enter image description here


  • Like OP, I am also using Windows 7, 64-bit.
  • Setting it to 'Windows Vista' compatibility mode doesn't work for me.
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.