We have two computers in the house (and two Day Z "accounts"). On one of these computers, it is not possible to save items past a certain point in my inventory. After playing around with it for far too long, it seems that once I pick up more than one pistol magazine (or possibly bandage), my inventory becomes "stuck" such that any additional stuff I get disappears when I logout and any items I consume re-appear on login. My health and location save as expected. Dying clears the condition, but new characters run into the same problem.

On the second computer, Day Z works perfectly for both accounts. In other words, the character whose inventory is stuck on one PC has no problem collecting things on the other PC. This fact makes me think I can do something about it rather than chalking it up to a buggy alpha. Here's what I've tried:

  • dying
  • lots of different servers
  • updating the game, including the latest beta
  • "verify integrity" of the Steam downloads several times (this is what I use to switch accounts)
  • I bought a third Arma key, and a fresh character under that key had exactly the same problem (again only on the buggy computer)
  • deleted everything Arma/DayZ-related I could find and reinstalled
  • waiting several minutes on the server before logging off (thinking it might only save my game periodically or something)

One more bit of info: on the buggy computer, my character seems to get "desynced" often such that my friends think I'm stuck in one place when I'm actually far away. Both computers share an Internet connection, so it doesn't seem to be typical lag.

Needless to say this was very frustrating the first couple times it happened. Does anyone have an idea as to what might be wrong?

  • Maybe DayZ is not using TCP to transfer save data (though it really should be...), and maybe that computer has high packet-loss for some reason. Try something like ping -n 100 google.com or check your TCP 'segments retransmitted' or UDP 'receive errors' under netstat -s (should be less than 1% of packers sent). Jul 26 '12 at 17:09
  • Good thought, though both my pings and netstat look solid. The other problem is that it seems to be quite reproducible: I'm good right until I start filling up my ammo/bandage belt.
    – ladenedge
    Jul 26 '12 at 19:07
  • Easy solution: re-install windows. Jul 31 '12 at 20:26
  • @BrentHacker: heh, I'm afraid I'm not willing to go that far. Looking for something of slightly lower impact!
    – ladenedge
    Jul 31 '12 at 21:01
  • @ladenedge Have you checked windows firewall and made sure arma II is added to the exception list? I would suggest disabling it and testing to see if that does it
    – Halfwarr
    Aug 1 '12 at 4:05

If you have a high desync with that computer, it suggests a problem with networking/firewall on that machine. Do you have antivirus scanning packets going in/out? Maybe try adding the arma2 executable to an exception list (do not scan things that program sends out / receives).

Otherwise I have noticed I keep items sometimes if I use them and immediately logout. Similarly, I have lost items that I have found by logging out shortly after finding them. Make sure after looting / using items you wait five minutes or so before logging out. It may also be a problem with the dayz server you are playing on (or dayz version, or arma2 beta patch version).

Have you tried using Dayz Commander and updating arma2/dayz to the most recent versions? It is pretty painless to do so through Dayz Commander.

If none of this fixes your problem, I would seriously consider asking this question with more detailed technical specifications on the official dayz support forums. You may have found a legitimate bug in the game.

  • 2
    Several of these answers have already been covered in the question. Also, the save time is 90 seconds for items.
    – Domocus
    Aug 8 '12 at 21:30
  • Do you have a source for that? Aug 9 '12 at 15:43
  • Not sure of where I first heard it, but it has been buzzing around the forums for quite awhile, as well as my clan's forums.
    – Domocus
    Aug 9 '12 at 19:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.