I downloaded Gods and Kings yesterday and everything runs fine, no glitches whatsoever. But there's one thing that's weird or odd about it. I see a lot of YouTube videos and screenshots and it's all normal as well. But the terrain coloring is different compared to mine and the ones I've seen in the screenshots and YouTube videos. The terrain is oddly dark, like the grass is supposed to be green but its very dark dark green, even the sand is very dark.

When I say dark, it's not the low-brightness-setting dark, because it's on high. It seems to be the terrain and models as well. The leader videos are all normal. I have screenshots of this problem.

  • Your screenshot didn't work, can you edit your question to try and add it? Or at least just provide the link and someone else will embed it for you.
    – Oak
    Aug 2, 2012 at 6:27
  • @Oak Both of the screenshots in the link worked for me. o.o; It's odd, the wheat tile looks normal but the underlying plains UNDER the wheat is almost like it's washed out. Have you, by chance, tried verifying your game cache/uninstalling and reinstalling yet? Aug 2, 2012 at 6:47
  • i reinstalled steam and civ5 all together, whats wierd is that it wasnt like this before the gods and kings dl. verifying game cache? sorry im not so smart :(
    – James Cho
    Aug 2, 2012 at 6:49
  • It seems like im the only one with this problem :(
    – James Cho
    Aug 2, 2012 at 7:00
  • @JamesCho To verify your game's cache, when you have opened your Steam library, right click on "Sid Meyer's Civilization V", and click Properties. In the menu that comes up, click the Local Files tab, then click "Verify Integrity of Game Cache". This will check all local game files for the game and, if any are corrupted, replace them with non-corrupted ones. Have you also tried launching the game with Gods And Kings disabled through the DLC menu in the main menu of Civ V? Aug 2, 2012 at 9:49

1 Answer 1


If the redownload does not fix the problem, you could look at the following:

Have you tried changing the graphics settings (not brightness but detail levels)?

What graphics card (GPU) do you have and which driver version did you update to? Have you tried other driver versions (stable or beta)? At least Nvidia's latest beta drivers mention a compatibility fix:

"Fixed a compatibility issue with Civilization V and GeForce 400/500 series GPUs" http://www.nvidia.com/object/win8-win7-winvista-64bit-304.79-beta-driver.html

Depending on your GPU, you could also try looking at the settings provided with the manufacturer's control panel software. They may sometimes override game settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .