In Minecraft, when you are nearby a large unlit area (underground caves, dungeons, etc), you hear ambient sounds, many of which are very unsettling and all of which sound unnatural. These can be particularly nerve-wracking when playing alone on a multiplayer server and trying not to be found by enemy players.

Is there any way to disable these sounds, or at least modify them to sound less frightening?

  • Turn Music: OFF, Sound: Off.
    – childe
    Aug 3, 2012 at 5:58
  • 2
    And if those scare you don't ever play the Cradle level of Thief:Deadly Shadows or you'll be in a rubber room for the rest of your life.
    – Alan B
    Aug 3, 2012 at 8:07

1 Answer 1


You need to replace the files with empty ones to disable the ambient sounds, but Minecraft will put them back how they were at launch unless you prevent it.

I'm using the ambient cave sounds as an example, but you can browse around the newsound directory and repeat this with other sounds you don't want.

  1. Back up the existing files (in case of ...something. OK, they're self-healing, don't worry too much).

    Assuming you're on Windows, they are located in: %appdata%\.minecraft\resources\newsound\ambient\cave

    Copy them away somewhere if you want to keep them. There should be 13 files with a .ogg extension.

  2. Replace the files with empty files (or something completely different if you fancy - in OGG format).

    First delete all the existing files. Then create an empty .txt file and rename it to cave1.ogg, copy/paste that and rename as required until the directory looks like it did before.

    As suggested by Koviko, you can automate this if you want. Create a batch file in the empty directory with the following content, and execute it as an administrator:

    @echo off
    echo. 2>empty.ogg
    attrib +r empty.ogg
    for /L %%i in (1,1,13) do (
      mklink cave%%i.ogg empty.ogg 
      attrib /L +r cave%%i.ogg

    This creates an empty.ogg file and then creates shortcuts/symlinks to it for the rest. It's faster than doing it manually.

  3. Protect your files from being replaced

    Select all of your new files, right click and go to Properties, then select the Read-only tickbox and click OK.

The next time you start Minecraft, it detects that the files have been changed, and tries to replace them with fresh ones but finds that it can't overwrite the files in that directory. In testing this I've not noticed any errors or other weirdness as a side-effect, so it seems to work ok.

An alternative to this is to use something like Sound Mod Enabler, which will probably allow you to make any modifications you like, but personally, I like to avoid using mods to do things I can achieve in the OS anyway.

  • This seems needlessly complicated, if all you need to do is turn off the sound.
    – Frank
    Aug 3, 2012 at 18:21
  • 6
    @fbueckert If you just want to disable ambiance and not music or other sound effects, this is the correct answer.
    – user3389
    Aug 3, 2012 at 18:46
  • 1
    I emptied the directory, built an empty *.ogg file in it named empty.ogg, opened CMD (in administrator mode), navigated to the directory, and ran this: for /L %i in (1,1,13) do mklink cave%i.ogg empty.ogg & attrib /L +r cave%i.ogg. I haven't got a chance to play yet, but Minecraft updated itself and didn't overwrite my symlinks. Now, to find out if the symlinks will work, or if I need to make actual copies of the music file.
    – KOVIKO
    Aug 3, 2012 at 20:02
  • @Koviko that works nicely. One thing to add - mark empty.ogg as read-only too, as for some reason that will get replaced too. In my case, it was replaced with 27KB of silence, so it may not matter. Strange though.
    – Simon
    Aug 4, 2012 at 14:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .