I'm currently attempting a side quest called Cloak and Daggers, and I'm trying to get to a mystery quest marker that appears in my HUD but not in my map. I've been wandering around for about 15 minutes now, trying to figure out how to get there.

As you can see: View 1 Map 1

The marker seems to be inside the building. I can't find a way inside. I checked the map on alternate levels but the marker doesn't appear on any level of the map.

Here's a view from another place, looking at the same marker: View 2 Map 2

But here's where it gets really strange. If I stand in certain places, sometimes the marker moves elsewhere. Here's a set of images with the marker in a different location: View 3 Map 3

It must be part of the "Cloak and Daggers" mission, because I have no other side missions available. I am tempted to believe that it part of the objective labeled: NEUTRALIZE ALL MCB OPPOSITION. I have killed everyone near that original objective except Double-T, who I knocked out, yet that phase of the mission is still not marked as complete.

What is going on, and how do I finish that objective and get to this marker?

  • Uh, did you actually check every floor on the map? I can only see the screenshot for the ground floor in your screenshots. Aug 6, 2012 at 0:42
  • @JamesJiao Yes. I didn't include screenshots of every floor, but I checked all of them. Aug 6, 2012 at 0:43
  • Which stage in the quest are you? Have you talked to O'Malley yet? Aug 6, 2012 at 0:54
  • 2
    The fact you've got quest location indicators means you selected the wrong difficulty at the start of the game! You're going to have to start again from the beginning, so sorry :*(
    – kalina
    Aug 6, 2012 at 14:08
  • 1
    aha I was just poking fun. There are quite a few quests in Detroit that have similarly weird markers that are not exact for the location they're indicating you should be going to. If you open up the quest log and look for S4 while in that region, what quest does it advise you're on?
    – kalina
    Aug 6, 2012 at 14:46

1 Answer 1


That's a bug in DE:HR, it happened to me, too. One of the gang members has wandered off to some point where you can't reach him. I would point you to a specific website, but none of the suggestions I found helped directly.

Otherwise, google for deus ex cloak and dagger bug and try out a few things.

I opted for the possibility that the gang member is one another roof somewhere and tried to shoot him (without seeing him), but that didn't work. All out of a sudden, the marker started moving and he was back in the flat, so I could finish him off.

  • 2
    I think I got around this by going back to the apartment block and shooting an automatic weapon into the ceiling for a while. It attracted his attention and he "teleported" back into the apartment.
    – agent86
    Sep 20, 2012 at 13:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .