I'm playing Minecraft on a mac, and I'm using a Logitech Revolution MX. When scrolling in the game, it flicks through my items very quickly, rather than one item-per-click scrolling than I get in Windows. Is there any way to get sensible scrolling through items?

  • Does the mouse have smooth scroll on it? If so, replace your mouse.
    – Ronan
    Aug 7, 2012 at 11:34
  • @RonanForman The mouse can switch between 'clunky scroll' and smooth scroll. On Windows these behave as expected. On Mac, even clunky scroll behaves like smooth scroll.
    – fredley
    Aug 7, 2012 at 11:36
  • @QAdley Does the MX not have a hardware switch for it? I know my VX did.
    – SaintWacko
    Aug 7, 2012 at 15:30
  • @SaintWacko Yup, but regardless of which mode it's on, the scrolling is smooth.
    – fredley
    Aug 7, 2012 at 15:58
  • I work in an office with a few Macs, and some of the users around here use Logitech mice. The problem with many of them (that work with both Windows and Mac) is that they behave a little inconsistent-- even between use in OS X and Windows 7, through Parallels. There might be an answer to your question, however, there is a good chance that this may be a bug that you have to live with.
    – RLH
    Aug 7, 2012 at 17:12

3 Answers 3


The hardware button should properly switch between smooth scrolling and single line scrolling, irrespective of the OS its plugged into. I'm not sure why its not working for you.

That said, Logitech Control Center is now supported in OSX, and it works with the Revolution MX. With this installed, you should be able to tweak the scrolling behavior.

  • The hardware button is just a signal to the driver. If the driver on a platform doesn't understand the signal, the switch won't have any effect. Jun 7, 2013 at 4:53
  • I was under the impression that the MX Revolution had onboard memory, like the G9 and G9x, but I guess it doesn't. You can program those two mice in windows, and it remembers their settings when plugged into any computer, any OS. The hardware button on these mice properly toggles between modes regardless of any software being installed. Jun 7, 2013 at 5:41

It's a little old, but for anybody searching for a solution, I got a pretty decent one:

Logitech's Control Center is the one doing it! Remove it from your settings / uninstall it. I discovered this after doing a clean install and playing Minecraft for the first time.

To configure which button does what you can use the free and much more advanced software Better Touch Tool. There are no problems at all when using BTT instead of Logitech's Control Center and there are many more options.


If you go to system preferences > appearance there should be an option to turn off smooth scrolling, I am not sure whether this is for the mouse, or for scrolling windows using the bar at the side however.

  • There is no such system preference as 'Appearance', and a search for smooth scrolling has no hits.
    – fredley
    Aug 7, 2012 at 11:52
  • @QAdley My source was this. Maybe I was reading it wrong.
    – Ronan
    Aug 7, 2012 at 12:25
  • 2
    That article is from 2008, MacOS has changed quite a bit in 4 years...
    – fredley
    Aug 7, 2012 at 12:48
  • 1
    But you haven't tried to turn off smooth scrolling? (The one under System Preferences -> General: 'Use smooth scrolling')
    – Philipp
    Aug 7, 2012 at 13:22
  • @Philipp imgur.com/RAAaD
    – fredley
    Aug 7, 2012 at 15:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .